!!!911!!!Emergency!!!HELP If You Can PLEASE!!!

Hi folks..Yesterday the replacement for my dead Sugden arrived..A Pathos "Classic Remix Mk.II"(NOT the Inpol version)from Upscale Audio..All looked fine..My set up is an Acer 315 Chromebook,the latest version with Quad Core processor & USB 3.2/Gen.2 USB ports,lots of memory & processor speed,a Mogami USB cable to the Pathos..Fired her up & everything seemed fine..About 3 minutes in it started dropping out about every 5 minutes,then after about 10 minutes it completely stopped communicating with the Acer & disappeared from the choices of audio output on the Acer..Turned the Pathos off & back on..Same scenario..This went on about an hour then it started to work better,the drop outs only occurring about every 20 minutes or so..After another 2 hours of this & it completely cleared up,running about 90 minutes until it completely disconnected again..
 Now when I power up the Acer sees the amp as an output but as soon as the amp goes from standby to ready mode it drops out completely again..Now it will not communicate at all unless I power down & up again but as soon as the amp switches to ready mode it's gone again..I have tried all USB ports on the Acer,using a high speed USB hub,plugging into a different Chromebook,finally pulling the amp out,plugging the Audiolab M-One I had been using back in where it fired right up & works fine..
 Waiting on UpScale to get back to me thought I would check here see if someone had any other possibilities to get this going so I don't have to pack it up,send it back & wait for a replacement,which I'm not even sure will work any better...Thanks very much & merry Christmas...


Unless someone else here has had the same experience with the same setup, your vendor is best source.  Or a very specific google search for the issue on the specific equipment will often yield good info if it’s a common problem.   Pathos is a somewhat esoteric brand so having a vendor with good customer support is especially important for when thjngs like this come up.  

You might check to see what usb driver is configured on the computer. It could well need to be changed to one that implements USB 2. Trying different usb drivers may well help. Default drivers on a lot of home computers are often not designed for best results going to an external higher res audio system .

I have run PC to Cambridge Evo 150 via usb and had to explicitly set USB mode to usb 2.0 and a different driver on the pc for best sound quality. Did not have disconnect issues but anything is possible case by case


Update:As soon as I finished posting the above I plugged an optical cable into my smart tv & ran to optical in on the Pathos,works fine,no drop outs,no disconnects..WTF???Thanks much..
PS:Supposedly Chromebook doesn't use drivers,only Mac & PC...

I’d initiate return and look for other safer routes to avoid unnecessary clashes with the store or manufacturer. Return while covered by the store as see this issue with Pathos here not first time. I speak from the stand point of QA engineer (Quality Assurance).


Just to close this out,when the folks in Italy were ask by the UpScale tech about this they replied "whats a Chromebook"...USB on these are designed to run off PC or MAC drivers..Chrome OS not recognized by the Pathos,never should have worked at all,the hour or so it actually worked was blind luck..
 Just going to get a good Glass Toslink cable & run from there..Even then it's still the finest sound I've ever had..