Anyone using Luxman m900u with Audio Research Ref6


Hi,
     Is anyone using Luxman m900u with Audio Research Ref6? I have it in my system and I feel something is a little off and I'm not sure what it is. My current set up is,

Vimberg Tonda Speakers
Luxman m900u - Amp
Audio Research Ref 6 - Pre Amp
MSB Discrete - DAC
Lumin U1
VPI Prime Signature
Oppo 205

It sounds good really well most of the time and sometimes I feel the synergy is a little off. I'm not sure whether it is my high sensitive speakers or the DAC or the Audio Research. It drives me crazy sometimes. Considering Luxman cl-1000 now. I'm not even sure whether it is Audio Research Ref6. Most of my gears are new though. Just wondering what could cause this. Any suggestion is appreciated.
karurravi
"It sounds good really well most of the time and sometimes I feel the synergy is a little off" ....

Fluctuating sound quality could have many potential sources, but variability in the electrical grid supplying the power would be a leading candidate.  Are you using any power conditioning?
Since you have a ARC preamp and are talking about that kind o money definitely look at the ARC REF 160s. It is magic and the synergy with the other ARC equipment is incredible. I have Sonus Faber Amati Traditional speakers which have the same impedance as yours. As I flipped each piece of equipment to ARC Ref... the synergy just took my system to new levels. I am constantly glued to my system now, it has a sense of rhythm and pace I have only heard with gutless systems before yet with an amazing soundstage, detail and power.

If you are having doubts, read some reviews. There is a reason the REF160 is wining awards everywhere.