Arcam SA30 issue with input

So I have my new amp since December . It’s been reliable so far but I have mostly been streaming as this is a new option for me. But now I am getting back into some CD’s and vinyl. I have found that on occasion when I select my CD input I get no sound. My CD transport is running but no sound. A few times I just changed the input back to Net and then my CD again and it works. Today I had to turn the SA30 off and back on again for it to work.

Has any one else had this happen? I don’t know how to determine if it’s the Arcam or my NAD CD player. I am using the optical input if that means anything.

On a possibly related note, my Tidal Connect would not connect last night also. Again, I rebooted and it worked again. Do I have a lemon?


So I did the factory reset and at first I saw no change. Those missing items were still missing. But then I thought what if I use the menu button on the front of the amp instead of always trying with my remote. Sure enough, there they were. I then tried using the remote once again and the setting are there. Very strange.

Anyway, everything is where it should be. Now I just wait and see how the SAT input functions going forward. Hopefully this has cured something


Oh and I must add that I just reread my original post. I kept saying CD input. What I meant was SAT input as that’s where the CD is plugged in.In my head I was accessing the CD. So apologies for the typo and confusion if there was any

I was originally going to mention not to use the remote but neglected to. Happy to hear that you solved the problem!