Aurender Conductor App

Is anyone else having a problem with this app? I can't seem to connect, I reached out for support but haven't heard back.


Did you try calling them? But their support is only open Monday to Friday. I tried to post the number for you but AGOn wouldn't accept my post. Try here:

Do you have a large house? I had similar problems once. It turned out that my ethernet cable connected to my Aurender needed to have a slaved router in my basement and that router had died. My main router, upsstairs, simply was not "talking" to the ethernet in my basement connected to my listening room and it made perfect sense except that by all appearances my basement router was fine when it in fact was dead. 

Network connection issues can happen with WiFi extenders too. Make sure your controlling device is truly connected to the same network as your Aurender. Just this morning I tried to connect to one of my streamers, but Conductor couldn’t find it. Panic ensued, until I realized my iPad was connected to a non-functioning WiFi extender. Good luck!

+1  This ^^^^

Your Aurender and iPad/tablet MUST be on the same internet network you originally paired them on.

This causes 99.99% of problems. Example, you go out and use mobile internet, get home and my Aurender doesn't work anymore!!!!!!!!!!!

Operator error.

Hi guys, if you ever run into any kind of connectivity issues like this, here is how to troubleshoot:


First, please check that the Aurender is on and has an IP address. You can check on the IP address at the bottom of the screen on the Aurender itself. Depending on what screen you are on, it may or may not display the IP, but you can toggle through different screens by pressing the menu button (3 lines, top right in the square of buttons) repeatedly until you reach the screen with the IP address. 

Does it have an IP address or does it state "No IP?" If it says "No IP," please double check the physical ethernet connection. If all connections are intact, try restarting your router and/or any WiFi extenders or wireless access points that may be in use.

If it DOES have an IP address, then please double check that your iPad or Android is on the right WiFi network, quit the Conductor app and reopen it. 

In case the app is still not “seeing” your Aurender at this point, please delete the app and reinstall it. IMPORTANT: on Apple devices, you must grant the app permission to access devices on your local network when prompted! Otherwise, it won’t be able to see your Aurender.

If you are getting stuck at this point please let us know via phone or email.

Thanks, and wishing everyone a happy Memorial Day weekend.