Cary Audio SLA-70B amplifier


I have no schematics for my SLA-70B and Cary Audio no longer offer technical support on this very old [27 year old] amp.  The LED light on the front panel of my SLA-70B Signature Amp does not work [does not light up]. Upon my opening the bottom panel I noticed that the positive side of the LED was “just hanging in the air.  Also a resistor 100K 5W was totally blown up so I cannot take a reading of it at all.

[I don't know why I cannot include an illustration of the issue in question]

The negative of the LED is connected. The positive (orange wire) is just floating loose.  There is a resistor 100K 5W which is connected to GRD and the other side has blown up.

I do hope someone can allow me to upload an illustration. It will definitely help in solving this issue.
Thanks, richfrank

128x128richfrank
I think I’d be all over Cary. HEY! Provide some service or provide the info I need to fix it myself. I’d get someone on the phone to tell me I’m SOL, then I would tell them, bad mistake, you guys are going to be my hobby, and it’s going to get ugly, your call.
OP that is what I found in 1 minute, honestly one minute..

I would look at ANY Cary. See how the power LED is wired up.. There's a hint, take it..

OLD HEAVY MASTER MECHANIC ret.

Regards
I could open up a Six Pac or V12r and take a peak. All I have on hand, currently. I'll bet they are all pretty close..

Regards.. 
richfrank,
If you have a photo sharing site, you can post a photo here with the hyperlink.