DAC USB Hum


I’ve had my Innuos Zen Mk3/MHDT Orchid DAC setup in my system for 30 days or so and I’m very satisfied with this combo. The Zen is USB only. Just noticed today that I’m getting a slight hum from the DAC and it goes away when unplugged. No hum through my speakers when connected just the DAC. Any help with eliminating the hum is appreciated.

cetla416

fuzztone- reread my post. You can’t get any further downstream than my speakers. At what point am I confusing my Streamer from my DAC? I make it a point to ignore your posts. The other responses are very helpful as they understand my issue pretty easily. Thank you erik_squires and jacobsdad2000. I have a few devices on order.

@erik_squires I am a firm believer in EverStar Galvanic Isolators for LAN and they do work! I appreciate your contributions. 

@jacobsdad2000 Thank you for your kind words.

 

I do use those hospital grade Ethernet isolators also but as much for surge protection as anything else. Based on readings from tech journals, it seems the best option for inside a building. I have a couple of long runs that end in expensive gear. The longer the run the more likely you are to have an induced surge from a near by strike.

I can't say that I've ever heard them make an audible difference yet. :)

Op also may want to look at the quality of the USB Cable being used. I have has great results with DH Labs as well as Supra Excalibur USB cables. Supra is a bit less expensive and would look into them. https://www.madisoundspeakerstore.com/computer/
https://silversonic.com/products/

 

@fuzztone it can also be a shielding issue in either USB or LAN cable.

Hum is a grounding issue.