help! no sound

Hi Audiogoners-

I am just hooking my stereo up after several months of inactivity during a renovation project.    I run a bnc out from my cd player to a Schiit bifrost (using adapter there for bnc).  I have RCA cables to the Lyr 2 amp.  When I play the cd player I get no sound.  (The cd player is producing sound through the speakers.)

This set up worked before and I am mystified.  Any idea what's going on?  Should I sent the LYR 2 back to Schiit for a repair?  Or is this user error?

Thanks for any insight!




Based on the setup, I assume your speakers are active/powered. The most likely thing to fail in this scenario is the tube. Turn off the power and remove the tube, power up and try again, the Lyr will the switch to solid state according to the site. Another thought is to plug some headphones into the Lyr and see if you get sound there. Lastly, or firstly, is the Bifrost set to the RCA input?

I don’t understand when you say you say the cd player is producing sound through the speakers.  CD players usually don’t make audible noise except music.  Sometimes you can hear a disc spinning noise but is if you are physically close to the cd player and not being transmitted to the speakers.

  Check both the CD player and remote to see if you have a mute button that may have somehow activated.  If that fails see if the DAC has a mute setting.  And if all else fails just unplug everything from the electric mainsand then reconnect and try again 


Thanks for your help.

To be more clear- I run an RCA cable from a cd player to an amplifier that connects to my non-powered speakers; from that same cd player I run a bnc out to the Schitt bifrost.  That is the then connected by RCA to the LYR 2.  So since I got these messages I did a few things:

- made sure I selected the right input mode on the DAC. 

-pulled out the tubes and tried it without

-ran rca directly from cd player to Lyr 2.

None of this produced sound through the headphones.  This makes me think that the LYR 2 needs to be repaired.

Anything else to try?