Hum problem


Been chasing a hum in my VAC Ren 30/30 for quite a while.  My technician has been all through it and does not find a problem.  Says he cannot hear it in his system, but it's quite apparent on my Horning speakers (94 dB maybe?).  As soon as the soft start relay starts to open, it begins to be audible and when it clicks open it's fully audible, maybe from 5-6' away, with the pre-amp fully attenuated.  Once you advance the attenuator past about 9 or 10 o'clock, it starts to get louder, but not before.  It's not a transformer mechanical hum; no sound at the amp but clearly audible through the mid range of the speakers.  Present w no other components turned on (or any/all turned on).  No change after swapping out power cords, lifting ground, swapping interconnects.  Changing the position of the ground switch on the amp has no impact.  Same w AC straight from the wall or w AC from a Dodd Audio Balanced Power System iso transformer.  Since this is a transformer/tube amp (not an OTL), I assume there can be no DC offset, and cannot really check that because I don't think I can operate it w/o a speaker load and the info I find on the web says it must be checked w/o a load.  

Any ideas before I ship this 85 lb beast back to VAC?

128x128swampwalker
@audiotroy 
1.  Mondial magic isolator already installed. 
2.  Will have to check dimmers but usually lights off. 
3.  Floated ground at wall and at power conditioner. 
4.  Hum is present regardless of whether other components are on or off. 
5.  Will try, thx. 
6.  I/Cs have no impact.

@almarg- @almarg- forgot about that; will swap out 6SN7s one at a time. Thx. 
 Have not tried lifting ground on preamp but the passive is a 2 prong plug so methinks that may not be it. 
My technician has been all through it and does not find a problem. Says he cannot hear it in his system, but it's quite apparent on my Horning speakers (94 dB maybe?).
See if you can hire the technician for an hour or so to come to your home and listen to the hum first hand.

Jim

Not a bad idea, Jim. I’m a regular customer and he lives in my town. If Al’s idea of swapping out the 6SN7s doesn’t work , i’ll give him a call. 
Could be induced hum (it doesn't do it in the tech's system). Is it possible to move the amplifier to another corner of the room and see if there's any change?
Did the technician put it on the scope?  If not what are the efficiency of his speakers?