InnuOS Sense 2.6.0.

The update contains a major upgrade to Sound quality. My Zenith Mk3 sings like never before. Any similar experiences?


Thanks for the reply @painter24 

I’m sure the Node is the weakest link in my system, but going into a Denifrips Pontus ll has it sounding really good. I can only imagine how great a better streamer would sound.

I’m hoping that I can have the same joy soon.

I did the InnuOS 2.6 update (successfully?) along with some older updates at the same time. My Innuos Zen Mini MKIII is second hand and was still running InnuOS 2.2.5. It worked fine beforehand, but now I can only rip cd’s (still retrieving album art and song data), but cannot play them back. I don’t currently have a Tidal or Qobuz account, but Internet Radio is not finding any stations. The unit is seen in the network via, but that’s about it as far as I can get. When I try to playback ripped CDs, the songs never start. The timer never advances, nor can I use the slider bar to advance it. Volume level is turned up and I can browse through my collection, pull up any album and select any individual track.

I’ve searched through the updated Sense app menus for a solution, reconnectted to no avail, restarted and unplugged the unit, reinstalled the Sense app, restarted my iphone, reconnected the wiring (tried both analog and USB/DAC) and reinstalled the Ethernet cable, but nothing. When connected to my DAC (internal to SA-KI Ruby) is says USB-DAC Unlock, which from what I can read, means that the signal sequence is not recognized, but as I tried to connect using the Innuos analog outs via the Zen’Mini’s internal DAC to my integrated (PM-KI Ruby), that also did not work. I thought maybe the update to the Innuos made some incompatibility issue with the DAC in the SA-KI, but since the analog out set up did not work either, thought it was something else. Note before I installed a USB-DAC cable, I had been using the analog outs, so positive both connection methods were functional prior to downloading InnuOS 2.6

I could not find a similar situation online with respect to InnuOS 2.6, and I tried to read through any user issues with previous versions, but still nothing much new.

I placed a help desk ticket yesterday and awaiting a reply from an Innuos tech. Until then, I’ll just sit and enjoy the unit’s good looks. Ha ha. Have to love the process more than the end result, but boy will it be good to resolve the issue.




There is an Innuos group on Facebook. The last time I had issues I posted on there and someone helped me resolve the problem before Innuos could get back to me.

@shredsled, curious to know if you tested at each update interval or only after you got to 2.6?

I'm also interested to know if Innuos support gets back to you over the weekend. They are usually pretty responsive but am not sure if they do weekend coverage. Updates for me have always gone off without a hitch but if they don't get back I will probably refrain from doing updates on Fridays (just in case).

I did the 2.6 update yesterday and it is working fine but I am streaming from Tidal. Just as an FYI, most music streaming services have free trials, you could sign up for one to see if streaming makes a difference? Good luck. 

jperry and chilehed,


Thank you both.
I did see the Facebook group, but don’t have a FB account so l’ll check via my wife’s account.

With respect to the update, I started around 11pm and didn’t realize there would be so many between 2.2.5 and 2.6. I was following along in the Sense app for some time, then my iPhone screen timed out. When I went to wake it, the Sense app was trying to find the unit, but didn’t, so I just let it roll overnight. Awoke at 4am and same issue, Sense app didn’t find the unit. It wasn’t until 7am or so that the Sense app recognized the unit and I received the system update successfully completed message.

From there I looked at the update log and I was surprised to count 10 version updates. I then tried to navigate around the app to see what’s new and that’s when I discovered the issue(s). I tested a cd rip and was surprised to see that work. Then began all the on/off, unplugging/plugging, connecting/reconnecting, etc

I held off on doing a factory reset as I would loose all my ripped cds. It’s not a ton as I just purchased the unit 2 weeks ago. It might be what I have to do, but will wait to get a reply from Innuous.

Hoping I would at least see a response by Monday or Tuesday. Not sure if their techs work on the weekends.