InnuOS Sense 2.6.0.

The update contains a major upgrade to Sound quality. My Zenith Mk3 sings like never before. Any similar experiences?


@shredsled, curious to know if you tested at each update interval or only after you got to 2.6?

I'm also interested to know if Innuos support gets back to you over the weekend. They are usually pretty responsive but am not sure if they do weekend coverage. Updates for me have always gone off without a hitch but if they don't get back I will probably refrain from doing updates on Fridays (just in case).

I did the 2.6 update yesterday and it is working fine but I am streaming from Tidal. Just as an FYI, most music streaming services have free trials, you could sign up for one to see if streaming makes a difference? Good luck. 

jperry and chilehed,


Thank you both.
I did see the Facebook group, but don’t have a FB account so l’ll check via my wife’s account.

With respect to the update, I started around 11pm and didn’t realize there would be so many between 2.2.5 and 2.6. I was following along in the Sense app for some time, then my iPhone screen timed out. When I went to wake it, the Sense app was trying to find the unit, but didn’t, so I just let it roll overnight. Awoke at 4am and same issue, Sense app didn’t find the unit. It wasn’t until 7am or so that the Sense app recognized the unit and I received the system update successfully completed message.

From there I looked at the update log and I was surprised to count 10 version updates. I then tried to navigate around the app to see what’s new and that’s when I discovered the issue(s). I tested a cd rip and was surprised to see that work. Then began all the on/off, unplugging/plugging, connecting/reconnecting, etc

I held off on doing a factory reset as I would loose all my ripped cds. It’s not a ton as I just purchased the unit 2 weeks ago. It might be what I have to do, but will wait to get a reply from Innuous.

Hoping I would at least see a response by Monday or Tuesday. Not sure if their techs work on the weekends.


@shredsled I’m having the exact same issue. After the update to 2.6 everything worked fine for one album, then I went to bed. Update took 5 to 6 hrs to complete.

Today, roon and innuous see all my ripped and qobuz albums, each of my 3 endpoints, display all albums, notes and track selction yet won’t play a song. Volume is 100% and the progress bar does not indicate the song is playing, only flits back and forth along the line until I hit pause. Seems like for some reason, the song itself is not loading, or is not seen. I've never had this issue before. Did all the hard reboots you described and even switched my Zenith MK3 to Sense from Roon. Same issue. So I switched back to Roon core and nothing changed. Keep us posted on your resolution. I may have to start a repair ticket with Innuos as well.

Update: without changing anything, I can now play through the Roon interface one of my ripped albums but not Qobuz albums. However, Roon is no longer displaying all albums or able to filter by genre so, at the moment, I can't see if more ripped albums will play. I am now thinking that Qobuz or Roon is having a site problem, or that the update has various incompatiblility issues with these services.  I havn't retried Sense yet -- not keen to do so.


Yes. Very similar.

Apologies for my newbie question, but when you say your Qobuz albums, those are ones you’ve downloaded from Qobuz and are resident on your Zenith’s hard drive?

I’m new to ripping and streaming, so learning more as I go along. The Innuos seemed to be a great “one box” solution for my needs. Was great for the two weeks…hopefully, we can both find a resolution. I’ll be sure to post once I hear and get to work with Innuos techs.