Lexicon MC-1; DC-1 Power supplies


Has anyone else had a power supply die in their Lexicon MC-1, or DC-1 or 2?

It's happened to me twice now. They use what appears to me to be a pretty cheap switching power supply. Lexicon won't service these units for less than $600 (though for that they do a complete refurb). I had my DC-1 repaired a couple of years ago by local reputable shop and it cost $200.

I love the units for home theater. They sound great and are very user friendly for setup and control, but wonder about the reliability.

Am I just unlucky?
bdgregory
Yes, and Yes. Two times I have lost the PS on my MC1. Most recently two weeks ago. However, it is an easy repair you can do with a phillips head screwdriver. Go to Mouser.com and buy this. Delivered it cost $49.

826-NFS40-7610J
NFS40-7610J
40W +5.1 +15 -15 OUT
04/08/13
How does one know if it's the Power Supply or not? My MC-1 suddenly won't power on at all. No lights - nothing. Is this the symptom? Thank you.
If it's not a fuse (check that first), it's very likely the PSU. You can verify with a VOM meter if you know how. I don't recall exactly what the connections are, but you should be able to trace where the PSU power output connects to the main board and measure if you have any voltage there.
Thanks Bdgregory. Since the fuse must be internal, I'm procuring a new Power Supply before tearing apart the whole HT setup to extract the Lexicon. (A chore I surely relish..)
I took Allhaildawg's link and purchased the power supply from Mouser. Put it in the MC-1 and now we're up and running! Thank you Audiogon guys!!!!