McIntosh C50 USB Input Not Working

Long story short, having problems with the USB input on my McIntosh C50 pre-amp/processor. I use this input to process computer audio files (on a MacBook Air running Aurdirvana Plus). I was intermittently loosing the "handshake" between the USB port on the C50 and HDMI port on the MacBook Air. Contacted McIntosh, they advised me to do a firmware update. First attempt erased the USB audio firmware. Second attempt  froze the C50 rendering it completely inoperable. Tried all the McIntosh advised solution to re-set the processor, all to no avail. Sent the unit back to McIntosh for repair under guarantee. After 4 weeks I got it back. Pre-amp/processor working fine except there is no USB input. Tried connecting the MacBook Air up to my Oppo BDP 105 Blu-ray player, Aurdirvana found the USB input fine. Looks like the problem is in the C50. Before I send the C50 back to McIntosh for another 4 week, any idea what may be wrong and what I can do about it?
It could be the C50 is demanding too much power from the Mac. You can try an external USB 2.0 powered hub. As always, you first have to see if the problem can be replicated on another MacBook and another cable before you blame the C50. 
I have tried connecting another laptop and different USB cables, same problem every time, nothing could detect the USB port on the C50. It's as if the USB port is simply not there or disconnected?
Turns out the problem was relatively simple to fix. Turns out Magnolia (Best Buy) did not send the processor back to McIntosh for repair, they sent it to their own repair center. Here they loaded the processor firmware but not the USB audio firmware! As I thought, the USB port was effectively not there. After another 3 weeks I now have the pre-amp/processor working perfectly with fully update firmware (Processor and USB audio).

A special thanks goes out to Ron at McIntosh who was very helpful identifying the problem; even though McIntosh had nothing to do with creating the problem in the first place.