Nuclues plus bricked

Roon forced an update of my nucleus plus and its now bricked. Anyone else run into this issue?


Figured I'd give an update on this.

So, I have to send it back to Roon and at the moment it looks like it will be free of charge. which is good news.

I have had two Nucleus Plus machines stop connecting to my LAN.

I am three+ years into owning a Nucleus. It worked sometimes. But software upgrades always would through it offline. I have worked with Roon support and my dealer. It was always a pain.

Instead, I started running Roon Core on a Windows PC. It has been very stable for two weeks so far, and I am using it on several wireless devices. Roon is also working with my NAD receiver/Endpoint.

Roon ARC is also working now, for the first time! So fun and useful.

And, I purchased a Wiim Pro to stream Qobuz via Roon to my main hifi. (It arrives on Sunday). I am expecting good things.

Can’t wait to sell my Nucleus Plus. One of the least enjoyable products I have ever owned. Good riddance, I say. :-)

@panamintsteve, I’m sorry to hear about your negative experiences with your Nucleus+ units. I’ve had my Roon Nucleus Rev B for about three years or so since the beginning of the pandemic, and I’ve never had an issue. The Intel chip in the Nucleus is simple and essentially fool proof, so I can’t understand what could possibly go awry. Then again I don’t use mine for anything except picking music from Qobuz. 

Just a quick update on this, I have received the nucleus back about a week ago and all is working well again. Looks like they had to replace the motherboard from what I can tell.