Ok ..I have Maggie 1.7is on Magnarisers but one keeps blowing the "tweeter"


It's definitely the (now left) speaker as I have swapped them around. Driven by very upgraded CJ PV10AL and Emotiva XPA-2 - which has plenty of power and current to drive them. The whole rig sounds so derful to me. However, when I play anything over about 80dB (as measured about 8 ft from speakers in center) and only about 11 o'clock on volume control the same tweeter ribbon section blows its fuse! Drives me nuts! Yes it's loud but it's not that loud. My retailer agrees. But I am trying to avoid sending it back to Magnepan - they haven't been helpful at all on phone - except to say amp should drive them easily. 

Please don't recommend any new components. If you have nothing constructive don't bother replying. 

 

Cheers

John

 

 

jkf011

You will need a digital multimeter, like this:

(cheap, but good)

Read the instructions on how to test for resistance. Basically it is plugging the black lead into the COM jack and the red lead into the middle jack (greek letter omega). Set the scale dial to the Omega number scale for resistance measuring (start at the lowest, or 200 ohm setting).

Disconnect the speaker cables. Place the red test lead on the positive speaker terminal and the black lead on the negative. Make sure they make good contact. Read the resistance. Repeat for the second speaker.

If the two readings are different, there is a problem with the wiring inside and this may be causing too much current being demanded by the speaker. (By different it should be by two, three or more ohms.)

If the readings are the same, it does not necessarily mean there isn’t a problem. The multimeter may not be able to "see" the tweeter because it is being blocked by a capacitor in series with the tweeter. But if they are different, then you definitely know there is a problem. Calling Magnepan with this information may make them more inclined to be friendlier with you.

 

Post removed 

I had 1.6s with highly modded xovers for a few years with  no issues. Then I bought a pair of 3.5rs. I blew two tweeters in about six months. I decided it was time to move on.....

@jkf011

I will throw this one out there.

You never said how long you can listen to the speaker loud until the fuse blows.

First if there was a short circuit the fuse would blow immediately. So that can be ruled out.

There is another thing that could be causing the fuse to blow besides an overload. Poor contact pressure and or poor contact pressure and corrosion at the fuse connections can cause heat to be generated in the poor connection when loaded, (playing music loud) The heat will transfer to the fuse link/element and the heat can cause the small element wire in the fuse to melt and blow open.. The fuse should fit tightly in the fuse holder clips. Also check the wire connections at each end of the fuse holder for tightness, as well for corrosion.