Ok ..I have Maggie 1.7is on Magnarisers but one keeps blowing the "tweeter"


It's definitely the (now left) speaker as I have swapped them around. Driven by very upgraded CJ PV10AL and Emotiva XPA-2 - which has plenty of power and current to drive them. The whole rig sounds so derful to me. However, when I play anything over about 80dB (as measured about 8 ft from speakers in center) and only about 11 o'clock on volume control the same tweeter ribbon section blows its fuse! Drives me nuts! Yes it's loud but it's not that loud. My retailer agrees. But I am trying to avoid sending it back to Magnepan - they haven't been helpful at all on phone - except to say amp should drive them easily. 

Please don't recommend any new components. If you have nothing constructive don't bother replying. 

 

Cheers

John

 

 

jkf011

And, like I said I switched sides and it's always the one particular speaker. 

Is it at all possible to swap the crossovers? I know this is some work, but if it’s not the crossovers, then it’s the tweeter section that is drawing too much current. Thankfully it is fuse protected.

If you already know not to play them too loud, then you might consider bypassing the fuses altogether.

@jkf011 for some, bypassing the fuse wouldn’t be a problem. If you’re uncomfortable about doing that, then don’t! My thought is that your problem is in the electronics and not in the speakers themselves.

I’m saying this because there’s nothing about the panels that would cause the fuse to blow. You could feed those panels enough power to the point of it burning through the mylar.