Here’s one person’s view on Roon, what’s yours? - 5:34 - 10:00.



I am quite happy with Roon. Content customer for going on four years. Watching was a waste of time. Did not agree with the rant on Roon as the logic of his points were not flushed out or true. The point of Roon Labs being greedy by competeing with companies that make servers does not pass muster. I do not consider providing a free operating system for use with an off the shelf NUC platform fitting the description of greed.   

Mike needs to learn more about high end servers. Roon sounds good in Squeezelite Experimental Mode for sure, but I do find Innuos Sense sounds better.


He May want to contact the OP below as he is both experienced and knowledgeable on this subject.  


Ya, Mikey seems to go off on the deep end a lot lately.  I liked Roon when I had it for a year or two. Presently on the fence and putting feelers out before diving back in. But it seems, there's not a lot of great options to choose from.

I bought a lifetime membership in Roon the first year.  It was an excellent investment.  Currently resides on my Wolf Alpha 3SX server with no issues.  

Bought a lifetime subscription a few years ago after the first year. It's not perfect, but overall I'd say it's the best bang for the buck of anything I've bought audio related. 

i held out for a long time but bit the bullet paid for the lifetime... (xmas gift from s.o. LOL)... it was a pain to set up, core machine switches end points and all, but it is really excellent, and makes the overall experience and sound nicer... 

Naive question: he claims that Roon changed their software in a way that made it incompatible in a number of ways, causing heartache and great expense to a lot of people. 

Is that claim true or false?

“there's not a lot of great options to choose from.”

Have you looked into Aurender? Very robust and well laid out app interface and great sound. 

The nice thing about Roon is that you are not tied to a single vendor's server or DAC technology. I started out running Roon on my PC, then on a DIY NUC server running ROCK, then a SGC sonicTransporter i9 optical.

I've used multiple connections to my DACs including direct USB, a couple different Sonore devices, Bryston BDP-2, Auralic Vega G2, Bluesound Nodes, and Apple devices.

I don't know of any other system that has this kind of flexibility and connectivity with the exceptional user interface and excellent sound quality that Roon provides. 

I have no doubt that there are excellent vendor-specific solutions, such as Aurender, that may even have SQ advantages over Roon, but I value not being tied to a single hardware vendor and being able to control a wide variety of devices in my home from the same system. 

jaytor - Are you still using your Transporter i9, what's your favored method of Roon, which sounded better to you?

@high-amp - Yes, I'm using the Transporter i9 as my Roon server. For my main system, this is connected optically to a Sonore Signature Rendu SE, which is corned via USB to a Denafrips Gaia which connects i2s over HDMI to my Denafrips Terminaror Plus.

@high-amp - yeah, but the Denafrips DACs definitely sound their best using an i2s connection, and using the Gaia allows me to use the clock sync from the DAC. 

The Sonore optical Rendu that I used before I got the Signature was the best bang-for-the-buck. The improvement to the Signature was pretty subtle, but I was using a linear power supply with the optical Rendu.

I also have an Auralic Vega G2 (in my bedroom system) and a bunch of Bluesound Node 2i boxes (used for background music in other rooms) connected to my network. It's great to be able to put multiple endpoints in a group and play the same music in different zones in my house. 

Roon is making it difficult to save Tidal and Qobuz albums.  When I try, it gives me a message that the album has been saved...but it hasn't.  Sometimes if I try multiple times, it saves.  Other times, it works if I switch to a different version of the same album--Tidal instead of Qobuz or vice versa for example.  Some albums are saved with no problems while others are impossible to save.  Others on the Roon message board report the same issue.  I hope Roon tech support reads these boards and fixed it!


if you didn’t realize it already, roon will show you all available ’versions’ of any album where they may come from different streamed or stored sources, and different resolutions available...

so take album x - let's say steely dan's ’aja’... if you have tidal and qobuz, and a ripped file in flac, if you pull up the album on roon there will be a ’versions’ button, click that, and it will show you at least 6-7 versions of 'aja' you have available to you:

aja - flac ripped on local drive/nas

aja - tidal redbook 44/16

aja - tidal h-r 192/24 mqa

aja - qobuz redbook 44/16

aja - qubuz hi res 96/24

and so on... i just made up this example above to illustrate the point

key is -- when you ask roon to ’save’ the album, it saves the specific version you are playing... so you need to specify which one you want... then -- other versions are NOT saved... follow?

hope that helps and clarifies...

Thanks....but I've tried saving every available version of certain albums, one after another, and none of them is saved--even though a Roon message says they are.  The funny thing is that some albums are saved with no problems and others just won't save.  As I mentioned, others have reported the same issue if you look at the Roon forum.

Thanks....but I’ve tried saving every available version of certain albums, one after another, and none of them is saved--even though a Roon message says they are. The funny thing is that some albums are saved with no problems and others just won’t save. As I mentioned, others have reported the same issue if you look at the Roon forum.

very odd, might double check your networking integrity... computers like the roon core aren’t that smart... if it says it has done something, it has... wouldn’t send a false confirmation... i was getting alot of glitchy nonsense like this, and then i moved the core machine into the same room as the endpoint, did not run it over a distant set of house wired network lan nodes, and it all sorted out ....