Shanling CDT-100 Technical difficulties

Recently, I posted a thread about my problems with my CDT-100 remote. I finally disconnected the whole unit and took it back to the place of purchase. Wouldn't you know it. Everything worked perfectly. Upon its return, it worked fine for about one day remote and all. Now the remote is not working and I get no output from either the tube or solid state outputs? This unit is pristine condtion and handled with kid gloves, just like everyone else on this site. I don't know what to do. I use an Audience PC into a PS audio strip. I have also tried turning the unit on and off to relieve static BU. no luck. When the remote was working I switched back and forth from upsampling to std redbook, that used to work. Now I can't use the remote. HELP!!
Ag insider logo xs@2xbrett11
Dear Brett,

Try flipping the upsampling button on and off repeatedly.
Maybe this will free it up. Do you here a clicking noise inside the unit? It really sound like something to do with the relay.

Best Regards,

Kyle Takenaga
Kyle - The remote will not respond at all. This was the beginning of the problem, now nothing works. The player behaves as normal, BUT there is no sound output and no remote use. As I stated earlier, I pulled it out of the system and tried it in another. The remote worked as did the CD player, it also worked fine for a few hours when I got home and then the current problems began. I can't change the upsampling without the remote.
Why don't you call the Shanling Repair Guru:
Mitch Singerman

He's authorized, knowledgable & communicative. Good luck.