TEAC NT-505 impossible connecting to WiFi router o such LAN: help me please?

Hello mates,
I got my NT-505 3 days ago.
It seems to be working correctly but in my opinion all software in not the same level than the device: too aged & often no relevant documentation or support about.
However my big trouble is the NETWORK interface:  since first time I switched on, the NT-505 remains "for ever"  into NET configuring blinking state until it goes in power stand by.

1. RJ45 cable is ok - tested in several manners
2. the wifi router (1Gb fiber connection) is ok
3. the wifi router ether ports (4) are ok - I checked a bridged LAN configuration too

Testing the NT-505 Ether port It results:

1. the physical level of protocol seems working correctly just on-way: the interface recognizes correctly the bandwidth (Fast ot Giga in my case) end the packet coming from the router are buffered. No packet sent  to the router.

2. At protocol level no ARP session are involved hence impossible retrieve MAC address and trying to do something.


1. Being NET board logically split from MAIN board It's need a separate firmware(!!!): how can I upload the NET firmware if, as stated into documentation, I must use the mobile app and It's impossible connecting the device to such LAN?

2. NO menu interface to configure manually the net parameters.

May someone help me (tricks..., recovery sw,..., low level maintance menu...,...) 

Thank you a lot.

The regional service center I sent my unit to said they had not heard of the issue.  I may let them see this thread.
My own experience with NT-505:

I bought the unit directly from Teac six weeks ago, connected with 26 feet 8-cat Ethernet cord to my router. 
Weeks 1-2: no problem at all. The unit and app was working just perfect, no drop offs, no connection issues, no app failure. Everything was in line. 
Week 3: connection issues appeared, tracks errors and drop offs on almost every song, all the apps (HR streamer, Lumin and Esoteric) wasn’t working stable, function buttons delayed or no reaction at all... I tried everything - unit manufacturing reset, router reboot, Ethernet cable reconnection, apps reinstalled, iPhone reboot, Tidal reinstall and resign... no results, issues was returning every time...

Week 4:  I downloaded and installed firmware update for the unit v1.22 from Teac Japanese site.... 5 min job, using my Windows laptop and micro USB charging cable from my daughter’s old phone. 
Weeks 5-6:   after firmware update all issues disappeared.. so far everything works just great... the unit and apps is in line and working perfectly. 
I haven't had any issues with mine since I ran an ethernet cable to it and upgraded firmware.  Rock solid.
Same here (no issues) for me, but I've had mine for about a year.  Maybe something changed in manufacturing or something and more recent ones are more susceptible to issues?