Anyone know where the Virtual Systems went?

I used to be able to click on a UserID  > details > .....  to see the authors (virtual) system. Now all I see is discussion list and responses list. It seems like the Virtual System Link is gone although sometimes I could swear that I see the text "Virtual System" pop up for fraction of a second. 

Is this is happening to anyone else? It seems it started right about the time that "bot checking" began. 

I've tried from:
1) iPhone

2) iPad

3) MacBook Pro

4) Win 10 desktop

All systems are updated with latest patches from the respective vendors.

 Please chime in if you are also experiencing this. 

Thank you for your time.


curiousjim's avatar


1,188 posts


It’s working now.

Still not working for me - at least on my Android phone.

Will try later on pc/Mac.

FWIW, I cleared the browsing history/cache on my Windows laptop - still not showing systems after clicking on ’Details’, just Discussions and Responses.


@elliottbnewcombjr I'm looking forward to seeing that turntable with three tone arms. Is one of them for a mono cartridge?