Naim Core Server, CD stuck, ejection button produces mechanical click

Yes, there is a pinhole access panel on the front to accommodate a paperclip insertion and manual ejection.   I applied quite a bit of force to no avail.

Tried with unit powered up and unplugged.  Powered up, I tried paperclip/access hole pressure while pushing eject button.   Any helpful suggestions would be greatly appreciated.  NOTHING WORKS!

Carefully fed another CD trying to trigger something and it wanted to take that one too!

Thanks again for useable suggestions.  Cheers

Post removed 

Wow! I’ve used this product since it began and have not heard of this happening. There is a mains switch on the back of the unit and a standby switch on the front. Try turning off the mains power for a few seconds and while depressing the standby switch on the front turn the mains back on. Keep the standby switch depressed for 10-15 seconds or until you hear the cd feed initialize. If the disc hasn’t come out try the eject button again.

If all else fails your best bet is to email support at Naim directly or search the articles/posts on their forums. good Luck!