Theta Data Basic Transport Repair

I’m sure there’s some former Data owners on here that can answer my question fairly quick. I just acquired a Theta Data Basic and a DSP Pro Basic II. Haven’t tried the DAC but the Transport does not work… I’m sure no one is surprised. 
When I first powered on the transport the display came on but the drawer would not open so my first thought was the gear wheel drive. Could hear something rattling inside so my guess on that was correct. Pulled the drawer out of the case and indeed it’s destroyed.

When I pulled the drawer out and load a CD it does not spin the disc and ERR comes up on the display. Question is, does the same gear spin the disk so maybe this is an easy fix or no it’s a bigger problem and not worth the fix? The gear is cheap but quick search looks like eBay and sellers are in China. The case is in great shape so if I can fix cheap I’ll save it. 
Have not tried the DAC yet but the toggle switch (paddle snapped off) for polarity is busted so I’ll need to change that out.

Greatly appreciate thoughts on the gear if that also spins the drive.
About 10-15 years ago the drawer on my Data Basic quit working and it turned out to be "the gear". I called Theta and they said they had one left and, for $100, they'd ship it. This is for a nylon gear no bigger than an inch in diameter, as I recall. They had me by the short hairs so I bit and made the repair. The unit still works to this day. I do not know the answer to your question about whether the gear works anything else, but I doubt it does. This is just a gear, I wouldn't be overly concerned about the source of the part.
Not concerned where the part is coming from as it’s only $15 or so. Only thing that might be an issue is if the drawer isn’t closing properly then it sees it as an error. The gear is totally shredded so surprised the drive for the disc went out at the same time. I’ll properly buy the gear and see if it fix's the problem. Cheap and it’s an easy install.

I know this is an old thread, but hopefully this comment can help someone with similar isses.

I had the dreaded drawer failure to open problem. Research way back when said that the gear and drive pulley were no longer available from Theta (or elsewhere). I boxed up the unit, bought a replacement, and moved on. Since I’m an equipment hoarder, the unit sat unused in the closet.

Recently I came across the unit in the closet and decided to relook for the gear. Amazingly ebay had them from a seller in China, so I decided to take a chance and order one.

Disassembly was rather easy, save for some fiddley small screws. The drive mechanism is attached from underneath the base plate, so some gymnastics are required to release it without dropping it. One ribbon cable needs to be detached. A small circuit board on the bottom of the drive can then be detached (but not necessarily unplugged). The pulley, gear and small plate can the be slipped out. Remove the old pulley, clean the shaft, and slip on the replacement. The unit can then be reassembled, taking care to center the drawer in the faceplate cutout.

Unit now works great.

This is worth the effort, since this machine uses the Philips CDM9 Pro laser assembly. This mechanism is legendary, and is still being used in the new Jays Audio transport.

One other note - the seller from China does supply a replacement belt, but it’s the wrong size - hold on to the old one!




Hi bama214

Yeah I bought the gear shortly after first posting and the drawer works great but still get the error so my guess the laser is dead. I don’t think the Jay’s Audio transport uses the CDM9 Pro as Philips stopped making that drive along time ago. Looks like Jay’s Audio is using a Philips but is a CDPro2-LF. Glad yours is working.