How to wake up a sleeping Genesis Digital Lens?

Some years back when my unit went into undocumented sleep mode the tech at Genesis ( no longer in business?) told me to do some sequence of remote control button pushes to turn unit back on. At least that's how I remember it. Has anyone run into a situation where simply pressing the power button fails to turn on the unit? Remote batteries fresh and strong. Although my Monarchy DIP works well, I would like to use the even better Digital Lens again.
If you have the machined aluminum remote, the "mode" led must flash green. If the mode led flashes red, the remote will not work the lens functions. You need to press the mode button and the led should change to green. The remote has a dual function to operate other Genesis components. I hope that this solves your problem.
If you cant find the solution, call PS audio ask
for Paul Mc Gowan the main designer of this unit
I think Doug Goldberg designed the Digital Lens, as he has been a consultant for Audio Alchemy, Genesis, and PS Audio. Paul McGowan probably knows about this, and if not, he can reach Doug. I think Paul's email address is

Brian Walsh
Thanks for the ideas. Tomorrow I'll hook in the Digital Lens
and press the mode button on my machined aluminum remote. Knowing the designer is active allows for the ultimate backup. Your help is a great feature of our Audiogon community.
Pressing the mode button in order to change the color of the led signal light did the trick. Thanks again to all who shared their knowledge of item and its designer(s.)
Recently purchased a Digital Lens used and when I received it the remote control was not working. Opening the remote revealed 2 corroded batteries. I replaced them with fresh one's but still no action from the Lens and no lights coming on from the remote. Without the remote working the Digital Lens will not power-on. How can I replace the remote (new or used), or re-program an off the shelf remote to work with the Digital Lens? Thanks in advance. Btw, the remote is the heavy aluminum one; also, tried the methods on this thread but the remote still is not working. Please help!!