Innuos 1.4.9 update available and 2.0 new info

Information on the status of the 2.0 update is available on the site.The 1.4.9 update has to be done first and has been available a few days.
I tried updating to 1.4.9 on my Innuos Zen Mk3 and it didn't complete then I couldn't access it on my network. Sent an email to Innuos the next morning and they promptly responded and reinstalled the software and updated within a couple of hours. I was very impressed with their service. Hope others don't have the same issue.
Update was OK on the Zen Mini mk ii, took only a couple of minutes, but on my Zen mk ii it had not updated in 30 mn and I mistakenly closed the update instead on minimizing it to send a note to Innuos and then could not find it on my.innuos. Sent a note Sat and waiting a response.
@oldears That was the same problem I had last Thurs eve. Sent Innuos an email Fri am and they responded right away and fixed it by 11am Friday (June 11). Hope they get to yours quickly. 
My Zen-Mini-Mk-3 updated within seconds and didn't miss a beat.  Yahoo.  That being said, I'm a bit disappointed that 2.0 will only include Qubuz native at first so since I use Tidal I'll stay with roon for now.  Actually if Innuos would just enable Tidal direct that would be a perfect solution for me.
Does anybody know what’s different (if anything) between the sound quality of version 1.4.9 vs 2.0 ?
I’m updating my Zenith mk3 to 1.4.9 (before going to 2.0) but I’m not sure it worked as now the Innuos server can’t be found on my network. Is it OK to turn off and on the Up the device using the physical button to reboot the server or will this screw up the update?