Streaming: WiFi or wired??

Looking to get a new streamer for a system based on Kii Three. WiFi signal is good but I’m also told that wired is always better. Specific streamer advice also welcomed; (no need to rip CD's). Thx in advance for any/all advice!
I'll second larry's notion on CAT6. I have a new Node2i that I started with wifi. The setup was a challenge.  For networking reasons, I moved my router from another floor to the stereo cabinet in my lair. When I hooked up the provided ethernet cable, I was impressed with a lower noise floor, etc. And there was no setup.
Upgraded to AQ Pearl and am like a pig in mud.

Anyone believing they're getting "better" or "clearer" SQ from wired vs wireless ethernet (or vice versa) has fallen into one of those confirmation bias traps we humans are prone to falling into.

Empirically and physically THERE IS NO DIFFERENCE in the final correct and intended data received by an ethernet network endpoint, whether wired or wireless. IT's IDENTICAL if the associated networks are performant. Read @cakyol's replies above then read up on tcp/ip, application protocols and the OSI network stack model.

ps: and all those snake-oil peddlers of "audiophile" network gear? Best-case is they don't understand ethernet network science, and are running their businesses for the usual reasons. Worst-case is they do understand ethernet network science - and are running their businesses for the usual reasons + engaging it with less-than-honest intent.
There are so many ways to slice and dice streaming. Wired is best, but a solid wifi mesh is excellent. Orbi works well. I run ethernet Cat7 out of the Orbi.Streamer is Ultrarendu from Small Green Computer. Uses Roon/Tidal/Qobuz and my ripped CDs. I run ethernet from Orbi into an EtherRegen custom ethernet switch. It really improves the sound. Then connect Ultrarendu to switch. UpTone audio sells the custom switch and great power supplies. 
Good routers let you prioritize service to specific devices.  I was having weird dropouts until my daughter found a "Max Connections" settings deep down in the LinkSys router configuration that was set by default  to 12.  Upped it to 50 and everything is solid.