Theta Data Basic Transport Won't Read Disc

Hi All,

I have a hand-me-down system including a Theta DS Pro basic III and a Theta Data Basic Transport. When I insert a CD, it says "Disc" and won't play.

Any simple home remedies, or should I take it in for servicing?

Sometimes the onboard computer goes out of whack. Try turning off the power switch on the back of the player and also disconnect the power cord. Leave off for a few minutes and then reconnect power cord and turn on and try again.This will sometimes work. If it does not work the first time, try repeating a couple of more times. It is of course also possible that the laser has burned out or that there is another problem with the transport. I have had the same problem and doing what I have told you might just work. The tech at Theta had suggested this to me when I was having the same problem. Good luck.
I had a Theta Data Basic Transport that did the same thing. Nothing I tried fixed it. Theta told me it was a bad laser assembly. The laser assembly that's in that unit, isn't made any longer. Theta had to retrofit a new laser. Cost was $300-$400 dollars a few years ago.
It is prolly a bad laser, which is no longer available. My advice sell it for parts and get sth new.
The transport is at least 10 yrs old and not worth the time and effort in comparison to what is available today
Thank you all, I will try the power switch/cord remedy, and if that doesn't work I will likely sell it for parts. Should I do so on the Audiogon site?
Hyoster - sure, place an ad. I was recenty LOOKING for one through "Wanted" section, and got one for $150 from a fellow Agoner.
Hi All,
I also have a same CD Transport and found out the gear driving the CD door open/close is broken. See the picture linked below. Please let me know if anyone know where I can buy a new gear. It would be a great help.