Black Ice FX DAC set up

I’m having some trouble getting my new Black Ice FX DAC DSD WiFi connected to my PC, and was hoping maybe another owner of the same dac could offer me some guidance.
Unfortunately, when I connected it to my PC, Windows was unable to locate the device driver for the DAC. The DAC does not appear on the list of playback devices under the “audio devices” heading. I attempted to search for an updated driver through the Windows control panel, but that was also unsuccessful. My operating system is Windows 8.1.

Since I was unable to connect directly via USB, I attempted to to connect via WiFi by setting the input on the DAC to “WiFi” and typing “http:\” as indicated by the user manual, into the address bar on my browser. After a short wait, the browser displayed a “can’t reach this page” error. Windows Network Diagnostics indicated that “Your computer appears to be correctly configured, but the device or resource ( is not responding.”

To be honest, the manual is not great, and at this point I’m pretty much stumped.
rfnoise is a private IP address. IPs that end in .1 are used for Admin logins on home routers/certain enterprise routers. Strange why they would ask you to key that in...


https = hyper text transfer protocol secure.

If this doesn’t work, download the driver from the manufacturers website under "support" or "drivers"

Then download foobar as your universal music player. Download and install the DSD plugin for foobar. Along with this, ASIO. You will need this so the DAC automatically switches between bit depth and sample rate with each song/file you play. For example, .wav at 16 bit/44.1 KHz

Hope this helps...
You need the driver.
Or forget connecting to the noise box via ANY method.  
Get a streamer.
@mastering92 yeah I tried the https. I also tried logging in as admin to my router, see if it was detecting the dac. Nada. I dunno... networking solutions not really my schtick. The network adapter in the DAC is from some Taiwanese company called Savitech. No help on their website.

As far as the USB driver goes, I checked Jolida’s website, doesn’t look like they have drivers available to download. I sent them an email, so hopefully they’ll be able to help me out. Hopefully.