Can't get the M2Tech Hiface Drivers to download

Every time I go to the Hiface website and attempt to download the drivers to my Mac the only thing that downloads is the installer package itself, not the actual drivers. Anyone else have a similar problem? Months ago I did this with ease but later fried the unit in a thunderstorm and the Mac stopped recognizing the unit, so now, with the new modified unit from John Kenny I cannot get the Mac to accept the new drivers - only the installation package. I have tried to download the drivers from the Geek website but have not been able to get that portion of their website to come up.

Anyone with similar issues that got resolved?
As a matter of fact I just downloaded the OS 10.5 driver myself two or three days ago. No problems, and it even self-installed.
Well, I must be doing something wrong. It says that it has successfully downloaded but the only place it shows up is in "downloads" and that tells me that it should be going somewhere else. I did this last year with no problems and see that the original download is still in the Mac with my latest endeavors showing up as modifications. There must be one more step to get it out of downloads and into the proper place. My Midi set-up will not recognize the Hiface at all. Last time it recognized it immediately. It was almost "plug and play"
Have you shut down the computer and then turned it back on? Sometimes that will load the drivers.
Yes, I have done that thanks Tgrisham. I am beginning to wonder if the problem is with the Hiface itself.
I am a Windows person, so I am speaking from a position of ignorance, but did you unzip the downloaded .zip folder (which I believe can be done in recent Mac os's by simply double-clicking its icon)? And did you then locate the .dmg file which would have been extracted from the .zip folder when you double-clicked it, and do something to cause the .dmg file to install the driver? I suspect that "something" would mean simply double-clicking the icon of the .dmg file, but perhaps one of the others with Mac experience can clarify the exact procedure.

-- Al
Almarg: I did unzip the file and it gives me the installation program so I followed through with that (again and again like a circle) and the same thing starts all over again. It seems that there has to be a way to move the dmg file from "downloads" to another part of the Mac. This is so frustrating because the first time I did this back in March it was almost automatic - no muss no fuss.
I did this last year with no problems and see that the original download is still in the Mac with my latest endeavors showing up as modifications.
It might be worth first running the driver UNINSTALL procedure, described on page 13 of the manual, and then re-trying the install. Perhaps something that may still be present in the os from your previous installation is confusing the installer.

Hope that helps,
-- Al
Puerto-I am currently using M2Tech EVO with Windows 7 PC
System. M2Tech Website has 2 Zipped Folders, one for MAC/
and one for PC. I know for PC, that there are two Application Files. One is Setup32, the other Setup64. Based on your System, one or the other of these unzipped
Files has to be installed. Not familiar with your MAC. Is it 32 Bit or 64 Bit System? Geek Website EVO Driver Search
just defers you to M2Tech Website.
After installation of Drivers, I still couldn't get
Sound thru DAC. Had to go to Attached Devices, and right click M2Tech Device. Had to set default setting for
particular Digital Output (SPDIF, AES/EBU, I2S...etc).
You could try these suggestions after you have tried all of the others. It sounds like the File is not installing in your Program Applications. Check your Control Panel to
verify if M2Tech File is running in list of Programs. Some
have no problem installing M2Tech EVO, for others its a
MESS! Strongly suspect lack of consistency in quality of
each M2Tech Unit. There is just too much wild variation to
be entirely blamed on operator error.
All of this could be avoided by having Installation
Driver already loaded onto M2Tech EVO itself. $100.00
Western Digital HD Back-up, $100.00 Netgear devices
automatically load up installation Wizard/Drivers upon
installation. Must be too much trouble for a $500.00 Device. Some think that I complain too much, I prefer not
to be a Tool being endlessly tasked to save a Corporation
big bucks. Most don't see it as a problem. I see it as
additional cost to me, on top of sticker price, according to my math. My time is just as valuable as anyone else's!
Pettyofficer: Thanks for the input. M2Tech is NOT showing up in the list of applications. Neither is it coming up as an option under Audio Sound options or Midi Set-up so my guess is that the drivers are simply not loading properly. I have followed all of the suggestions offered by Almarg, Tgrisham and others without any luck (they were excellent suggestions) so I will just keep hammering away until something positive happens. I appreciate all the input - really! I am totally frustrated at the moment and need to give it a rest.
There is one other option still untried: The disc that came with the Hiface. I will find a friend that has a "slide out" CD tray on their computer and see if I can burn a copy to use in my Mac. The disc is one of those really small sized ones and for sure if I stick it in the iMac it will never come out again.
Puerto-still unclear as to what happened during Thunderstorm. Was M2Tech Hiface fried? Was MAC damaged during Thunderstorm? Is this the M2Tech Hiface, or the
M2Tech Hiface EVO? What type of connection are you using
with M2Tech Device. If USB, try another USB Outlet. Existing USB Outlet could be fried if M2Tech Device got fried. If EVO, try another Wall Wart Power Supply with exact same Voltage as the one that came with the Unit.
Power Supply could be fried. In any case the M2Tech Device
must be fully functioning, attached to MAC, and Powered up
during Driver/Software Installation. MAC has to be able to
see M2Tech Device first before Configuration changes can be
made during Driver Installation. Your talking M2Tech Device
to your MAC, and MAC says "what M2Tech Device, I don't see
M2Tech Device". Could be bad connection between MAC and
M2Tech Device, or M2Tech Device could be so fried that
connection is not possible. You might need to replace it
prior to installing Driver.

Sorry your still having problems.

When you go to Apple Menu/System Prefs/Sound and click on the output tab does the HiFace show up as a selection? (you do have it plugged in correct? Just trying to cover all bases.) If it is not showing up try using a different USB cable (if you are using one). If you cannot get the HiFace to show up, the unit may be damaged.

Try what Pettyofficer suggested and try another USB port or try another USB device on that port. Are you using a USB port on the Mac or a USB hub? Some devices don't play well with the hubs.

To check if the driver is installed open your main HD/System/Library/Extensions and see if a file named Hiface.kext is there. If it is, the driver is in the correct place.

Also what OS are you using 10.4, 10.5 or 10.6?
Pettyofficer: Here are the details: First, this is a modified unit from John Kenny in Ireland. The first unit from him worked perfect but that is the one that I think was fried in the thunder storm. Immediately following that storm the Mac no longer recognized the Hiface, however, the port is still good because my pop pulse functions perfectly through it. The charger unit that was a part of the modified version had/has a surge protector function and still works just fine. The Hiface batteries still function so I am dubious that it really fried the Hiface. Second, I got a second Hiface from John and the Mac would not recognize that one either. I have changed ports, cables, etc., everything you can think of. No where does the Mac show the downloaded drivers - no where. It shows my HP Printer Drivers with no problem.

Jamscience: Today I converted the small sized driver download disc that came with the unit to a full size unit (so I could use it in my Mac) and ran the download again. Nothing! I can't find the download anywhere. Maybe you are right - the problem is with the Hiface itself.

Many thanks to both of you for your suggestions - I take them seriously.
Hi Puerto,
jkenny here. I get google alerts on certain keywords & it alerted me to this thread.

I didn't know you were having problems with getting the Hiface recognised by the Mac.

Can I suggest that you try the Hiface on another computer to prove that it's OK, preferably a PC but another Mac will do.

Let me know how you get on.

Thanks for that idea John - Yes, I have a PC also and will give it a try. Never thought of that. I really don't think that there is anything wrong with the Hiface itself or your work - it has always been good. I have been unable to get the drivers to download so until I can accomplish that I have to assume that the Hiface is good. I even tried using the Hiface unit itself without any connections to the mods but with no luck.
My Apologies-Puerto. M2Tech Hiface is normally powered by
USB Output. M2Tech Hiface EVO has external Power Supply.
Thought you had Hiface EVO. You currently have a M2Tech
Hiface that has been modified to run on an external Power
Supply, and it is NOT an EVO? Just wanted to make sure that this was clear. If the first Unit worked perfect, with
the applicable Driver installed, then something had to have happened to that Driver on your MAC during the
Thunderstorm. Are you using any type of Back-up, external
memory card, external Hard Drive, Internet Back-up? Try
checking your Back-up for the M2Tech Driver there. Either
the MAC already has the Driver installed, or it lost the
Driver during the Thunderstorm. I would go with the latter-
if previous Unit got fried, good chance the Driver didn't make it either. Verify that you are indeed trying to install the proper Driver for your System-32 Bit, 64 Bit
whatever. Make sure that you are trying to install the most
updated Driver from M2Tech. Could be that the Driver Disk is out of date, but try it anyways. I sometimes get low
conductivity with one USB Outlet, with my Netgear Device, I
switch to another USB and everything is fine. I can still run other Devices on the former USB Outlet anyways-go figure! USB is a flaky connector. Make sure Hiface is connected, and powered up when you install Driver. I don't
believe MAC will install Driver if MAC can't see the applicable Device attached for that Driver. Check your
ATTACHED DEVICES to verify Hiface is there and MAC can see it-then install Driver.
Yes, all good ideas from pettyofficer. Just to explain - what Pete has is a stock Hiface that I modify to provide a clean supply to the on-board clocks via an internal battery inside the new box for the Hiface. This is charged by an external supply.

BTW, Pete (puerto) I have a modification for you when you get it all up & running which will solve the issues of system hangs that seem to only occur on the Mac when the Hiface is turned off. Email me when you get a chance, I don't seem to get any notifications about new posts on here!
Dweeb4 I am going to start with your suggestion to test the Hiface on another PC just to see if it will work elsewhere - an excellent idea and will keep you posted via E-Mail. Thanks for staying in touch.

Pettyofficer: Thank you also for your comments, I cannot find the "attached devices" section that you referred to. Perhaps in my OSX (10.5 Leopard) it is called something else. There doesn't seem to be a hint of the Hiface anywhere in the computer at all. I would have expected to see it under applications.
Puerto- my apologies. I am using Windows 7 System. MAC is
a little confusing. Is there anything in OSX that shows a
listing of attached devices (Printers, PC Monitors, Memory
Card...etc.)? If I attach any Device to my PC, that Device
will show up as a Symbol under "Attached Devices". Left
click that Symbol, and Windows 7 will tell me that this
Device will require an installed Driver. Windows 7 will
search for the Driver (in Windows 7 and/or the Internet), but, usually wont find specialty Drivers. The Attached Devices will atleast show that your Computer has good contact, and can see the Hiface. You still have to install the Driver, but atleast your Computer and Hiface have good
conductivity. There has to be a MAC equivalent. This would help verify that Hiface/MAC are working properly, the only thing missing is the Hiface Driver. This would be helpful as a process of verification, and elimination of the causes of the problem. You have to reach this point, BEFORE your System can accept installation of the proper
Driver. Hiface has to be attached, powered up, and be visible as an attached Device by your MAC, prior to Driver
installation. I am pretty sure that MAC, like PC, verifies the first three steps prior to proceeding with the forth.
The Driver you install has to match your type of System
(MAC,32 Bit, 64 Bit), and it has to be the most up to date
Driver that matches the history of your Hiface Device. Is
the Device an old Hiface requiring an old coresponding
Driver, or is it a more recent Hiface requiring the more
recent updated Driver? No reflection on Dweeb4, I am sure
you were sent the the most recent unit. I would still verify compatibility as a process of elimination to flesh out the problem. If you do all of these things the only things left are going to be, mechanical problem with MAC-
or Hiface, or Software problem with MAC. Are you sure that the Hiface is getting power? Showing up as a Device on your MAC would help verify this. Hiface has to be attached,
and powered up, and MAC see it, prior to any attempt at
Driver Installation will be successful.
Pettyofficer: Many thanks for your comments. They are well taken. I will take those steps.