Denafrips Aries II and Mac laptop issue

hi all

Recently got a Denafrips Aries II and I am trying to use it with my Mac laptops, both running latest MacOS Big Sur.  I seem to be having issues where the laptops either freeze up or become super slow when I connect the unit via USB. Sometimes it works, but then when i disconnect and reconnect Mac does not detect it anymore and the same problem repeats. 

I just installed the latest firmware too last night. Initially I thought it helped. But the same issues came back soon. Has anybody had this experience? I see this with both my laptops, one is older and other is very new.  Not sure if this is a Big Sur compatibility issue.

I primarily use Mac for my listening and if I cant get this resolved I will have to send the unit back.

Many thanks! 
Strange. I'm using a MacMini with Mojave, and certainly haven't experienced any related issues.

Have you tried emailing Alvin at Denafrips? He is typically very helpful, and may be able to further troubleshoot.
I’ve had my MacBook (Majove) connected to my Ares II via USB without any problems, but, I will say, it sounds better (cleaner) via my WiFi streamer/optical (in my setup). 
Hey guys, 

Please reach out to me should you experience USB compatibility issue with Mac. A firmware update of the USB MCU is required to fix it. 

Alvin Chee
Same issue here annoying, I thought my Mac was dying. So far best Solution is to just leave the DAC on all the time. Thanks will contact you for update firmware
@maelob - that is a different issue, and it's one that I told Alvin about a while back (and he said that no one else ever had that issue). Yes, if you unplug or re-plug in the Ares II, it will kill the Mac, requiring a power down and re-boot. That problem has existed since I first received the Ares II; I don't know that it is an Ares II bug (vs. a macOS bug), but none of the other 100x devices that I've used with a Mac have caused this problem.
@alvin1118 - I also shave the *new* USB issue with Big Sur. Sent you an email today. Is there a link to the fix that you can just fix publicly?
I also have weird issues with the Ares II and my older Macbook pro (which I will be most likely updating this year).  I need to make sure the DAC is selected for USB first before plugging in, or it freezes the macbook or my iphone, and I have to restart.  Then it usually works fine.
Also, I'm running Mojave, as a couple of my music interfaces were not working with Big Surr.

I gathered that the later versions of macOS had some changes to the sampling rate supports. 

For DENAFRIPS, we have make the necessary update to the USB MCU firmware so that our DDC/DAC are compatible with the latest macOS. 

We have published the firmware V3.4.1, it's tested compatible with macOS. Guide to update:

Hope this helps!

Alvin @
Update!  A few weeks ago I got in touch with Alvin, got the firmware update (had to use my wife's PC), but now the Ares II works perfectly with my macbook pro and two different iphones.  The new firmware fixed it.
I can’t seem to update. I got to the Update USB MCU.bat part but it says it failed 
It says file not found

xprog is not recognized as an internal or external command, operable program or batch file. Failed, please try again. 
Any ideas what I’m doing wrong?
Ok I worked it out. I’m not used to windows it’s like a foreign language. So I had to extract it first which I thought it was doing anyways. 
I am having the same issue. The firmware update looks very complicated, especially for a non-PC user (I won’t even get into the issue of having to find a windows laptop to do this).

olivermeyet, any tips that will help me avoid the issue you had?