Innuos Zen Mini Mk II with an Ayre Codex

Is anyone successfully using an Innuos Zen Mini Mk II as a server into an Ayre Codex?
ayre codex will work with any of a number of dedicated streamers... need Toslink or USB in though... no coax RCA or BNC
Codex would not work in harmony with my Bryston bdp-pi via USB. Had to use toslink input.
 The Zen mini mk 2 only has USB out. I also assumed it would work when I bought a used Codex. But I am having problems. I thought I had found the solution when I reset the latency of the Innuos to normal instead of low, but still have USB communication loss before I can finish one movement of a classical work.I am now using a very basic USB cable in place of the Straight Wire USB-Link, and it has lasted 90'.
I stlll would like to hear from any users with actual experience.

suggest you call into ayre ask for their help

they are great people, always been very responsive and helpful to me when i have inquired or needed help on anything pertaining to their gear
Just run the USB through a Topping D10s on the way to the Codex.
No brainer.
Of course I called Ayre, they suggested the very basic cable.Fuzztone, this is a no brain, NOT helplful reply.
when i had a zen mini i ran the toslink into my codex it was fine (used a lifatec cable)

i try to stay away from usb if spdif connection is available...

well good luck to you, hope you sort it out
Ryan Berry suggested I try a very basic USB cable in place of the Wire World USB-Link cable I had bought from Schiit.  I used the very basic 6' cable in the Codex box which had never been unwrapped. This solved the communication problem with the Innuos, and I was even able to go back to the low latency setting. He said using a USB upgrade cable is hit or miss.For those who have had some issues with USB communications, it might be worth a retry to go basic.A basic design feature of the Ayre USB DACs is the asynchronous Streamlength USB input.

You should touch base with JohnnyR at Audio Connection in Verona NJ. He has that setup in his showroom.
Updating this thread...I did get the Innuos Zen mimi mk2 to work with the Ayre Codex. After the Innuos 1.4.6 firmware update the USB connection appeared to be less touchy and all cables worked through the USB 2.0 jack.I sent the Codex back to Ayre to resolve several other problems, which they remedied under warranty. When it returned, it would not work at all from the USB 2.0 jack of the Mini, but happily did work on the USB 3.0 output.Happy with the sound, I was able to find a used Innuos Zen mk 2. Unfortunately it does not link at all with the Codex. Not with any cable I have, nor at either latency setting. The Zen mk 2 has only one USB output, no Toslink. The Zen does link correctly with the USB input on my Oppo 105, and through a Schiit Eitr into a Theta Gen Va. The sound of the Zen is better than the Zen mini.I have been in touch with both Ayre and Innuos. interestingly, both inquired as to whether the problem was the same with a generic USB cable.(the answer is same problem). The only special cable I have is a Straight Wire USB Link, which is not exotic, simply made with "better" materials.Since the Zen mini mk ii still works into the Codex (but only thru the USB 3.0 jack), and since it was just recently serviced by Ayre, they maintain it is operating correctly. They have communicated with Innuos, confimed their USB input is "class 2 compliant", and offered to work with them to resolve this type of issue. In talking further with them about cables, they confirm that because their input is asychronous, with 2-way communication, there is a requirement for high speed data transfer.The Codex does need the 5V power, and they suggested the Cardas Hi-Speed USB cable. This is a dual cable, but with only one A input plug.Not wanting to spend $400 on a possible solution, I have found a Pangea XL USB dual cable with seperate A plugs for power and data (I plan to put the power plug into the backup jack on the Zen).To summarize, it appears that some USB connections can be very cable sensitive.
It is a shame that such difficulties can arise between equipment brands, for which each manufacturer has a reputation for attention to good sound.If any Audiogoners have direct experience with this type of problem, I would appreciate their information.
Try to insert an Intona Isolator via USB. Alternatively an Uptone IsoRegen will likely solve the issue. The problem most likely relates to timing synchronisation of the USB data stream
Interesting suggestion, so I looked them up. Don't think it would help. My understanding is that the asychronous USB input on the Ayre depends on the clock in the Ayre dac to control the timing by calling for the data from the server to keep a buffer full. This means there is a 2-way transfer of data, which seems to be the disturbing difference. The Zen also seems to have a 2GB RAM cache, storing the data before transfer, which may be complicating the situation. Its beyond me. I can't believe I'm the only one trying to use an Innuos server with a Codex.
I received the dual Pangea cable yesterday. It did nothing to resolve the problem between the Innuos Zen Mk2 and the Ayre Codex. However, I did perceive an improvement in the "reality of the vocal image" listening to Allison Krauss when used from the Zen mini mk2 using the USB 3.0 jacks into the Codex.I am still waiting on Innuos to procure a Codex to figure out the problem.
I'm still not able to resolve that the Innuos Zen mk ii will not link with the Ayre Codex. Innuos has turned my question over to R&D. I found a reference on the web that there is a bug in the Linux kernel that causes a problem with all brands (naming Aurilic, Ayre, Aesthetix, Berkeley, Jeff Rowland) using the Wavelength protocol for USB connections and another reference with problems for the Allo USBridge. I forwarded the info to Innuos, Ayre and Wavelength last week. Waiting on a response.
Let me repeat my suggestion: as a cheap trial, get a USB hub from amazon inserted in your USB coneection. If that solves the problem, the Intona solution, while more expensive will be superior. I had the same issue between an Innuos Zenth Mk3 and an Antelope Zodiac Platinum
@antigrunge2 I don't understand why it would help, but if an Insignia USB 2.0 hub from BestBuy will work, I will try one tomorrow. 
 I received the same advice this morning from Nuono Vittorino of Innuos, so I went to BB and bought an Insignia USB hub. I installed it and immediately found lock and played for 3' before losing lock and jumping to the next track. Same thing for both choices of latency and with different cables.
Sorry to hear that. At this stage the only way forward seems to me to be people at Ayre. Good luck
I don't see how the Codex ( which works fine with USB from a PC and from the Zen mini) could cause the Zen server to skip tracks. At any rate, I am still in contact with Innuos (M. Vittorino) and I copy Ayre on the communications.
One other suggestion would be to use a Schitt Eitr to convert USB to SP/DIF, a solution I was using for a while before going the Intona USB route. In my case the Zenith won’t talk to the Antelope Platinum w/o the Intona Isolator
M. Vitorino questioned as to which USB hub I had tried and recommended a D-Link DHUB-H4. Based on this I went back to Best Buy and exchanged the USB3.0 Travel Hub for a 4 port USB2.0 hub with 5V external power supply. This has now been going for 2 hours! Problem solved for 20 bucks. Not sure why this works.
Congrats. USB sucks. It is far from a standard interface! Glad that Nuno sorted the problem, though. He takes clients very seriously.
I am sure you are now enjoying the music!
One additional suggestion if I may: insert an Intona Isolator behind the hub, I think you will be surprised.
@antigrunge2 I have continued to successfully use a USB hub, but didn't forget your suggestion and found a used Intona Isolator to try between my Innuos Zen mk II and the Ayre Codex. Unfortunately it does not work at all and I cannot get a lock with any cables on hand. (Surprisingly it did provide an improvement when used from the Zen directly into a M2Tech Hiface with a BNC cable into my old Theta Gen Va.) I have no idea of the difference in galvanic isolation it provides compared to the USB hub.
@oldears ,

Did you insert it after the hub? It’s normally pretty transparent for connection purposes. However, USB is by nature trial and error. Glad you got the original problem solved
I inserted the Intona instead of the USB hub. I can't imagine why one would want to use both.

@antigrunge2Silly me, I just inserted the Intona before the hub, and it links.So tomorrow I will compare how it sounds. (I also tried the hub before the Isolator and it does not link.)


Good to read that AYRE continues to provide excellent customer service.
Perhaps all of your diligent work will assist in creating an update for other Codex owners.

Happy Listening!
Crap!  Adding another cable and another box is not supposed to improve transparency. I seem to hear music leap out of a "blacker" background and better imaging. The things we (I) don't understand! Thanks to @antigrunge2 for insisting.

it’s a pleasure and what this forum is all about. USB is really tricky and experience counts. While I am at it: treat all your power and signal cables with Graphene Contact enhancer from You’ll have another fun moment enjoying the music. All the best.