Problem duplicating my external HD onto another one

when I tried to copy my (music files) HD onto another HD, it failed the same way with 3 different 'receiving' HDs: at some point in the process, it stopped, messaged that it couldn't complete the task because "________ (one of my music files) is in use", but I wasn't playing anything. it's no biggie; I had another copy, and can still use the problem HD for playback (it's even still letting me write new files onto it). I'm curious if anyone here has run into this or has any ideas. I'm a mac user, did 'disc first-aid' on the problem HD (it said it's fine). at some point I may just erase the problem HD, (try to) copy the whole archive onto it, then see if it'll allow itself to be copied, but if you have any ideas, I'd appreciate your input. thanks.

fwiw: the file that supposedly was 'in use' was different each time, so I think (?) that rules out that there's a corrupted file on the HD. not sure.
Either the target drive is suspect or it is the OS. If Unstoppable Copier stops it’s the drive. I had an internal that became not readable by the OS anymore. Removed and placed in a dock I salvaged all files (2.5 Tb), much faster than retrieving them from the cloud.
Your results on iOS probably vary.
That is odd.

Sometimes just having a browser (Firefox) window open whilst trying to eject a hard drive can cause issues on my Windows 7 system.

Or perhaps iTunes (or media player of your choice)³ is doing something in the background. Might be worth checking the Apple equivalent of the processes tab.

As an aside, never eject a USB from your car whilst the media system is switched on. There might be all kinds of interactions still taking place and sudden disengaging can cause loss of data.
Or even worse, damage the USB beyond repair!

As I've found out a few times, it's not the same as playing CDs.
@fuzztone: I tried to copy it to 3 different drives with no luck. I was able to transfer to one of those drives using a different source, so I think it's the HDD I'm trying to copy. it's solid-state, if that tells you anything.
@cd318: I didn't have any applications on when I attempted the transfer. the error message says '_________ file is in use' - since all the files on this HDD are music, that would suggest itunes (my player) is on, but it isn't.
fortunately, as I mentioned, I had a different backup, didn't lose anything. I ordered another SSD so I'll have 3 (not counting the problem SSD which, even though I can't copy it, still has all my music).
Can you skip the file and continue?  If so make note of the file and its location and then move it manually after mirroring the drives.