Problem duplicating my external HD onto another one

when I tried to copy my (music files) HD onto another HD, it failed the same way with 3 different 'receiving' HDs: at some point in the process, it stopped, messaged that it couldn't complete the task because "________ (one of my music files) is in use", but I wasn't playing anything. it's no biggie; I had another copy, and can still use the problem HD for playback (it's even still letting me write new files onto it). I'm curious if anyone here has run into this or has any ideas. I'm a mac user, did 'disc first-aid' on the problem HD (it said it's fine). at some point I may just erase the problem HD, (try to) copy the whole archive onto it, then see if it'll allow itself to be copied, but if you have any ideas, I'd appreciate your input. thanks.

fwiw: the file that supposedly was 'in use' was different each time, so I think (?) that rules out that there's a corrupted file on the HD. not sure.
Try restarting your computer. That often fixes a problem with a PC. Clearing cache is another fix but not sure it applies to Mac
What OS are you using? If Windows, have you tried making the copy in safe mode? Another option is to use cloning software. 
I have a mac (OS 10.13.6). I did see something online about software for copying HDs - maybe I'll go back, try to find the link, try that. thanks.
Either the target drive is suspect or it is the OS. If Unstoppable Copier stops it’s the drive. I had an internal that became not readable by the OS anymore. Removed and placed in a dock I salvaged all files (2.5 Tb), much faster than retrieving them from the cloud.
Your results on iOS probably vary.
That is odd.

Sometimes just having a browser (Firefox) window open whilst trying to eject a hard drive can cause issues on my Windows 7 system.

Or perhaps iTunes (or media player of your choice)³ is doing something in the background. Might be worth checking the Apple equivalent of the processes tab.

As an aside, never eject a USB from your car whilst the media system is switched on. There might be all kinds of interactions still taking place and sudden disengaging can cause loss of data.
Or even worse, damage the USB beyond repair!

As I've found out a few times, it's not the same as playing CDs.
@fuzztone: I tried to copy it to 3 different drives with no luck. I was able to transfer to one of those drives using a different source, so I think it's the HDD I'm trying to copy. it's solid-state, if that tells you anything.
@cd318: I didn't have any applications on when I attempted the transfer. the error message says '_________ file is in use' - since all the files on this HDD are music, that would suggest itunes (my player) is on, but it isn't.
fortunately, as I mentioned, I had a different backup, didn't lose anything. I ordered another SSD so I'll have 3 (not counting the problem SSD which, even though I can't copy it, still has all my music).
Can you skip the file and continue?  If so make note of the file and its location and then move it manually after mirroring the drives.
@tom6897 the problem SSD is western digital. I had another copy on a seagate HDD. I was able to transfer that copy to a 2nd western digital.

@danager I can't skip the file; it automatically aborts, doesn't give me that option. each of the 3x I tried to copy the disc, the problem file was a different one; on one attempt it got to ~80% done before aborting, another time <10%.
thanks for all the suggestions. at some point in the next few days, I'll  erase the problem drive, see if I can copy my files onto it and then see if I can then copy it onto another HD. even if it behaves at that point, I'll consider it a HD with an 'intermittent' issue, i.e. unreliable. with storage so cheap these days, I won't risk losing my music collection. at that point the problem HD (even if it's behaving) will just be a redundant backup (I'll have 3 copies of the collection elsewhere). I guess you could say it'll be a lightweight paperweight with a ton of music in it?
Can you copy the files in batches instead? You might be running into a memory issue as it tries to do a large # in one go.
New to me, never heard of a problem attributable to a source drive. My money is that it's most likely downstream starting at the connectors.
I cleaned mine but still needed a dock. 
@noromance breaking up my itunes library would be a major PIA, and since I'm able to do this action with other drives, not worth the trouble
@fuzztone I was able to transfer the files using a different source to 2 different HDs, each of which has its own cable. it just seems like I've isolated the problem to that one HD
thanks for all the ideas!

I used have this happen when copying a large library from one HD to another. Do not use the windows tools to do this, I use terracopy. It rarely fails with such large IO operations. I have about 2T. If you stick with the native windows tools usually can get it to finish by breaking the cooy operation into smaller chunks. Then when one fails not all is lost. Even in terracopy I do it in 3-500gb chunks just to be safe. 
@jbs thanks for the suggestion. the reviews of the mac version of teracopy are really negative, but I'll definitely check out more mac-friendly applications that do the same thing.
I am very impressed with your post because this post is very beneficial for me and provides new knowledge to me.

If I have the problem you are having with ssd drives I use a program from O and O Software called Safe Erase which  cleans every bit of information from the drive. I then reformat the drive using long format with 64kb formatting and then do my copying with no problem whatsoever. Has worked a few times with total success each time.  The company gives 30 days without the need to pay so you lose nothing by trying it.