Problem duplicating my external HD onto another one

when I tried to copy my (music files) HD onto another HD, it failed the same way with 3 different 'receiving' HDs: at some point in the process, it stopped, messaged that it couldn't complete the task because "________ (one of my music files) is in use", but I wasn't playing anything. it's no biggie; I had another copy, and can still use the problem HD for playback (it's even still letting me write new files onto it). I'm curious if anyone here has run into this or has any ideas. I'm a mac user, did 'disc first-aid' on the problem HD (it said it's fine). at some point I may just erase the problem HD, (try to) copy the whole archive onto it, then see if it'll allow itself to be copied, but if you have any ideas, I'd appreciate your input. thanks.

fwiw: the file that supposedly was 'in use' was different each time, so I think (?) that rules out that there's a corrupted file on the HD. not sure.
@noromance breaking up my itunes library would be a major PIA, and since I'm able to do this action with other drives, not worth the trouble
@fuzztone I was able to transfer the files using a different source to 2 different HDs, each of which has its own cable. it just seems like I've isolated the problem to that one HD
thanks for all the ideas!

I used have this happen when copying a large library from one HD to another. Do not use the windows tools to do this, I use terracopy. It rarely fails with such large IO operations. I have about 2T. If you stick with the native windows tools usually can get it to finish by breaking the cooy operation into smaller chunks. Then when one fails not all is lost. Even in terracopy I do it in 3-500gb chunks just to be safe. 
@jbs thanks for the suggestion. the reviews of the mac version of teracopy are really negative, but I'll definitely check out more mac-friendly applications that do the same thing.
I am very impressed with your post because this post is very beneficial for me and provides new knowledge to me.

If I have the problem you are having with ssd drives I use a program from O and O Software called Safe Erase which  cleans every bit of information from the drive. I then reformat the drive using long format with 64kb formatting and then do my copying with no problem whatsoever. Has worked a few times with total success each time.  The company gives 30 days without the need to pay so you lose nothing by trying it.