Problems with Innuos Music Library missing covers

I have been operating my Innuos Zen mk ii into the Ayre Codex through a USB hub. I have slowly been cleaning up the large library file by associating cover art where it is missing, but for the last 2 days it cannot find any covers. Has anyone had this recent problem?
I haven't. Are you up to date on the Innous software?
When coming against such problems, it would be best to contact Innous directly. They always answered my queries.
Firmware is 1.4.7. Sent Innuos a note Friday.
It finds a cover for new rips, but not for previous files which are missing the art for the last few days.
Ahh, I hate it when software goes wonky.
Though the remedy is usually something quite simple.
Give Innous a chance to remedy. 
If you don't get a response, let me know.


Response from Innuos today: " This is indeed a known recent issue. It's fixed and will be on the 1.4.8 update in a couple of weeks "
@oldears ,
At least, you know you are not alone.
Hopefully, the update will fix you issues. Even if it doesn't, I am sure Innous will work with you to find a remedy.
I did much the same with Bluesound. Though it was a bear to slog through, they did eventually find a solution.
The big problem with streaming is the integration of so many different programs from different vendors into a single app. I like to think we are on the cutting edge...
Interesting. I’ve had this problem a few times but a library rescan/rebuild has always fixed it. Good to know 1.4.8 is on its way given that 2.0 is expected by the end of May.
No update just yet. For the last week, the firmware is now finding the covers, but not allowing to save metadata changes.
No Innuos 1.4.8 update yet, more than a month since the problem was identified.I see that Innuos mentions a Squeezer app for Android phones for playback control. Has anyone tried this in place of Orangesqueeze?
The good news is that 1.4.8 is out.The bad news is that the 2nd attempt to update, I got as far as re-booting my server, and now doesn't find my Zen. Restart and other attempts fail!
I do not recommend to install the 1.4.8 update.
I have completed troubleshooting. I have verified from my router that the IP address of my Zen has not changed. I have not had any reply from Innuos. I have re-installed my Zen mini (without updating!) and it is working.The update has effectively bricked my Zen.
@oldears ,
Sorry to hear you still have issues. I had a similar issue with an Aurender unit and had to send it back for a replacement drive.
Hopefully, yours won't require it to be sent back.
Innuos is usually pretty good at responding, but sometimes things get missed. I would send another message.
The remote session did not fix my problem. It appears that the part of the upgrade disabling the IPv6 is causing a problem and it will have to be sent for repair.
A second remote session has me running again. The problem may have been a faulty library in a previous update.
That is great to hear.
I know that this can be frustrating, but you have to remember that so much of this is new. Add to that, Innous has to create a software that has to work with non related software.
Frankly, I don't know how Bluesound manages to get things working while integrating as many streaming apps that they offer.
 My Zen MKII is now dead after an attempted upgrade to 1.4.8. What did they do to get up running again?
The remote session that fixed it was somewhat complicated: I had to attach a VGA monitor and a USB keyboard to the back of the Zen which was attached to my router as usual; so it then becomes a stand-alone Linux PC. Then Nuno took remote control of my Windows PC and told me the commands to enter into the Zen (I think deleting the incomplete upgrade) to get it to the point that he could get the Zen to have a valid IP address again, at which time he took control of the Zen on the network to do the 1.4.8 update manually. It took nearly 2 hours.Go to to get the process started. I'm sure they can get it going, but you  may have to wait 'til after the weekend.After the update the Music Library can again be edited as before.
Thanks, oldears. I've "Put in a request for help" a couple of days ago.  I learned my upgrade lesson with MAC and wait a while before upgrading. I was so excited about the upcoming 2.0 that I upgraded to 1.4.8 before waiting a bit to see if others had issues. If I had done so, I wouldn't be in this bind.
I’ve had a similar issue, even after updating to V2 Innuos Sense. 3 weeks later, 3 emails to support an no answer. I suspect they have been overwhelmed with this release. 
Since the upgrade I found the OS thought I didn’t have an internet connection, but after numerous reboots it now see the Internet. But still no album art.

I also can’t use Roon with Squeezlight, it would be nice to compare Squeezlight with Spence and pick the the best sound quality. With no album art and no comparison I’m back to Roon and hoping I can roll back to 1.4.9 and let them stabilize this release.

Do understand that some have working upgrades, though this is disappointing to me that after 3 weeks not a single reply. If you upgrade do know there is some risk.