Unable to load files to Sony HAP-Z1ES thru network

I’m having difficulties transferring files—pretty much anything about 96kHz/24bit—into my Sony HAP-Z1ES through a wireless network. Typically, a few files will transfer, but then I’ll get an error message (in the Sony transfer app) saying a file can not be found. The transfer then stops. Any advice is greatly appreciated.

I have the same Sony and do not have that problem.  I have loaded many hi res files at once and haven’t endured what you are saying. Do you have the latest firmware that was released a month or 2 ago?  Have you tried transferring the files using the wired Ethernet?
I'm having the same problem as OP and even worse.  I use wireless to download to the HAP S1; don't have wired Ethernet.  I downloaded the latest firmware about three weeks ago.  I then successfully downloaded some new music.  But late last week, I saw that the machine's music files had somehow become corrupted, with many files being copied numerous times, such that on any particular album, there were 4, 5 or even 6 copies of the same track, and multiple tracks had that problem.

To try to fix this, I deleted all of the contents (music) and data from the machine and then tried to re-download them.  But I keep getting the same error message as OP that the file cannot be found.

As OP requested, does anyone have any suggestions?  I'm going to try to contact Sony support and will report back if I have anything.
This is a follow-up to my previous post.  I continued to try to fix the problem without consulting Sony Support.  In the process, I managed to screw up some Windows settings.  (Don't ask.)  I know almost nothing about Windows or computers but somehow managed to fix those problems.  I then uninstalled the HAP Music Transfer app, downloaded it, and reinstalled it.  That seems to have fixed the problem, as my computer is now transmitting music files and data to the HAP S1.  It's going to take at least 24 hours to complete the process; only 10350 files to go.  The only glitch so far is that the HAP Music Transfer app has twice stopped on its own accord.  So, I started it again, and both times it seemed to pick up where it left off, or at least I hope it did.

I've been pretty happy with the HAP S1 overall, but this is the third time that the Music Transfer App has become corrupted and inoperative, and I've to uninstall and then reinstall.

When I purchased the HAP S1, I thought that one of its advantages was having an internal hard drive, which I thought would provide more reliable performance than streaming.  I'll certainly reconsider that if and when I buy a replacement.  If I again purchase a machine with an internal hard drive, I'll buy one that allows for direct loading of music, in addition to either Ethernet or wireless loading.

So, Lepanto, if you're still having a problem, you could try uninstalling the HAP Music Transfer App and then downloading and reinstalling it.  Good luck!
I also have Sony HAP-Z1ES. I copy music files directly from Windows file manager without using the Sony Music Transfer program. Transfer using wireless is always slow, but transfer using wired connection is faster, up to 25 MB/s.
I do not use the Sony Music Transfer program with my HAPZ1ES, I use Windows explorer and just drag and drop.  I also upload the files to the Sony in batches, about 20GB at a time and never had any problems, lock-ups or otherwise.  It is not adviosed by Sony to upload large amounts of files via the wireless, Sony recommends the ethernet connection and to use the wireless for adding new files, once the big initial transfer has 
I have a HAPZ1ES and have used windows explorer to transfer music files. I  Have never had a problem. But I have never downloaded a huge file dump. Have never had a problem with any file corruption on the unit. These days I use a external disc drive to rip cd’s directly to the unit.