iTunes Ripping - Strange Digital Artifacts

I've tried a few variations on archive searches and wasn't able to find an answer to this: In ripping some of my CD's into iTunes (either Apple Lossless or WAV) I've been getting some very odd, brief digital artifacts at the end of each songs on a CD. This sounds like two or three seconds of an audio tape on fast forward. It only seems to happen on new releases (I cannot think of any older CD's it's occurred on). I just got a copy of Mary Gauthier's new album (great CD by the way) and it happened on that one. I tried ripping it multiple times in Apple Lossless, and WAV (always in iTunes) and each and every time it created files where this strange artifact existed at the end of every song. I play the CD I ripped the files from and the artifact is not there. Is this some kind of anti-piracy technology...or do I simply have some setting off in my itunes preferences (Error-Correction is on, WAV or Apple Lossless is always set to Automatic, have experimented with importing to startup disk and external disk-same results). The artifacts seem to always sound the same too...they never vary, except that they sound different from song-to-song, but the same if say, the first cut is played over again.

Anyone have any clues what this might be?

I use an Apple. Either a G5 tower (2.7ghz duo) or an ibook laptop. I mostly rip files on my laptop. I actually haven't given the tower a try on the CD's in question as I mostly use that for work. I'll give that a try just for curiosity.

Have you tried AIFF format? I've never ripped to WAV only Apple Lossless and AIFF and have never heard any digital artifacts that you've described.
No, I've never tried AIFF...only WAV and Lossless. I'll give that a try to see if the results are any different.

OK, I think I've isolated it to my laptop. I took the same Mary Gauthier CD and ripped it on my G5 tower. No artifacts. That was as a WAV file. So what's going on with my laptop (g4 1.42ghz iBook)? The settings are identical. Plenty of RAM. iTunes and system updates are all current. Hard drive has plenty of space to run. Perhaps a trip to the Genius Bar is in order! Order up another round of Mensa Ice Tea from the good folks at Apple. Any further input would be great - has anyone else experienced this?
Are you playing music or using other functions on the computer as your rip? I have had some problems if I was transferring files or playing files (especially if you are playing the CD as you rip it). I think that there may be a usb through put issue. If the folks at the Genius Bar have any thoughts/suggestions I'd love to hear...
Good thought, 4est. I don't think I was, but I'm pretty sure the USB connection was there and idle. Also, it would not be unlike me to do something else while it rips, but in this case, I've tried the same CD several times without doing anything else so it's definitely no that. In the case of the tower that ripped it successfully with no artifacts, there was definitely no output device connected, and nothing else processing while it was ripping. I will certainly post anything I learn here. Thanks for the input thus far.

You might check the settings on the Audio MIDI Setup on your ibook. You can find this in Applications/Utilities/Audio MIDI Setup. Since you got good results on your G5, if you see that the settings are different on the ibook, maybe you should conform them to the G5 and see if that helps. Of course, this changes the output settings, not how the file is ripped, but who knows...
Thanks, Jeffrey. I didn't think of that, though I'm not sure I'm following how it might have an effect. That may be mostly because I've never understood exactly what it was for. Those settings have gone unchanged from whatever the default is. The system on the Tower was imported from the laptop when loading the OS (Leopard) software so the two should be identical. Some of the affected rips were made on the laptop using Tiger as well, so it's not anything new in the software. I went in and took a peak at the settings. I'm not sure what I'd be looking for though(?)...just that the settings are the same? There seems to be only settings there for Mic and speakers. None of the dropdowns have any options available without any devices plugged in. The other option is to check Midi devices which is limited to the IAC driver and Network. Can you give me some direction as to what I might be looking for there?

Thanks for the suggestion...anything is worth considering at this point.

i think you would need to have your output device plugged in, then you can check the output settings for that device (sample rate, etc.). that said, if you haven't made any changes to them, the settings are probably still at the default so this may not be an issue at after all.

here's some interesting reading on the subject: Benchmark Setup Guide
Great link, Jeffrey. Thanks!

Since it shows up on the rip through any source I play the files through, I don't think the output settings have anything to do with it though. Even the file transferred to my iPod has the exact same artifact. So it is the original rip that is corrupt.

Now that you've determined the problem happens on your laptop and not your tower, you could also see if it's limited to one specific user account on the laptop. Try ripping the CD from another account, even if you have to create a new one for this exercise. If things are fine on other accounts, try deleting the iTunes preferences files from the Libraries folder in your original account. Or, with a little work, you could migrate to the new account as your main account and leave your troubles behind.
Just checked my one-week old MacBook w/ the end of a large # of tracks I have a disturbing artifact, too. In fact, it is is very electronic sound, a few little beeps, moving from channel to channel.

No idea what it is.

how do i get rid of it? Fortunately, I've only ripped a dozen discs in apple lossless format to an eternal firewire drive. No other activity on the computer. Dedicated system just for music storage.
Update...The electronic beeps, starting right channel and moving to left channel, don't exist on my IBM Thinkpad in apple lossless format, but they do on my Macbook.

I just ripped a four tracks that had the electronic beeps on my Macbook on my Thinkpad and on the Windows XP machine, the beeps aren't there.
Nycjdc - what you describe does not in any way resemble what I'm getting, but certainly could follow a similar path of investigation. Do you have "error correction" switched on? Which format are you ripping with (WAV, Lossless, AIFF)? BTW, for me, this did not start when I switched over to Leopard - I have several CD's I burned using Tiger that have the same artifacts. AFAIK all were ripped on my iBook, or so I suspect (I rarely rip on my tower). Interesting that we both have problems with ripping on Mac laptops. Thanks for posting.


PS Where can I get one of those "eternal" firewire hard drives! :-)
I'm using iTunes and ripping in Apple Lossless mode with error correction.

I used the same setting on my Macbook as I did on my Thinkpad. The only difference (other than OS) is that I ripped to my internal drive on the Thinkpad, while on the Macbook I ripped to my eternal/external firewire drive ;*|

marco, were you able to make it to the genius bar?
marco, were you able to make it to the genius bar?

I had a not entirely satisfying visit just this evening. Though they did find a solution, they could not really explain it. It may help you and others so I'll post what was suggested as a solution. Perhaps you could try what worked and let us know if it solves your problem as well.

The girl I was speaking with suggested that the artifact was the software misinterpreting information between the cuts. It was only a theory. She had not heard of any other incidents to relay. First she suggested I rip as MP3's. I explained that wasn't an option for me. She listened to a few cuts on a CD I'd brought with, or rather the ends of the cuts and confirmed there was a problem with the rip. She went through my settings, and asked if I'd tried it with Error Correction turned off. I explained I hadn't and that I preferred to use it. She suggested attempting to rip one of the cuts with it turned off just to see how it did. We did that and no artifact was there. So her 'solution' was to either leave error-correction turned off always, or turn it off for those problem CD's that produce the artifact (I'd estimate about 5% do on my laptop). This did not explain why it was doing it, nor why my g5 tower, which is running a carbon-copied system with all the same iTunes settings, does not produce the artifact with Error-Correction turned on.

In my case I have been experiencing the problems ripping to the internal (startup drive) on the laptop, as well as to an external (USB) drive.

I turned off error correction and the little beeps remain. So I turned it back on and re-ripped the discs. Interestingly, and somewhat disconcertingly, the little beeps have moved tracks. Don't have any idea what it is...and odd it doesn't happen on a PC (Thinkpad).