Problem duplicating my external HD onto another one

when I tried to copy my (music files) HD onto another HD, it failed the same way with 3 different 'receiving' HDs: at some point in the process, it stopped, messaged that it couldn't complete the task because "________ (one of my music files) is in use", but I wasn't playing anything. it's no biggie; I had another copy, and can still use the problem HD for playback (it's even still letting me write new files onto it). I'm curious if anyone here has run into this or has any ideas. I'm a mac user, did 'disc first-aid' on the problem HD (it said it's fine). at some point I may just erase the problem HD, (try to) copy the whole archive onto it, then see if it'll allow itself to be copied, but if you have any ideas, I'd appreciate your input. thanks.

fwiw: the file that supposedly was 'in use' was different each time, so I think (?) that rules out that there's a corrupted file on the HD. not sure.
Try restarting your computer. That often fixes a problem with a PC. Clearing cache is another fix but not sure it applies to Mac
What OS are you using? If Windows, have you tried making the copy in safe mode? Another option is to use cloning software. 
I have a mac (OS 10.13.6). I did see something online about software for copying HDs - maybe I'll go back, try to find the link, try that. thanks.
Either the target drive is suspect or it is the OS. If Unstoppable Copier stops it’s the drive. I had an internal that became not readable by the OS anymore. Removed and placed in a dock I salvaged all files (2.5 Tb), much faster than retrieving them from the cloud.
Your results on iOS probably vary.