Problem duplicating my external HD onto another one

when I tried to copy my (music files) HD onto another HD, it failed the same way with 3 different 'receiving' HDs: at some point in the process, it stopped, messaged that it couldn't complete the task because "________ (one of my music files) is in use", but I wasn't playing anything. it's no biggie; I had another copy, and can still use the problem HD for playback (it's even still letting me write new files onto it). I'm curious if anyone here has run into this or has any ideas. I'm a mac user, did 'disc first-aid' on the problem HD (it said it's fine). at some point I may just erase the problem HD, (try to) copy the whole archive onto it, then see if it'll allow itself to be copied, but if you have any ideas, I'd appreciate your input. thanks.

fwiw: the file that supposedly was 'in use' was different each time, so I think (?) that rules out that there's a corrupted file on the HD. not sure.
Can you skip the file and continue?  If so make note of the file and its location and then move it manually after mirroring the drives.
@tom6897 the problem SSD is western digital. I had another copy on a seagate HDD. I was able to transfer that copy to a 2nd western digital.

@danager I can't skip the file; it automatically aborts, doesn't give me that option. each of the 3x I tried to copy the disc, the problem file was a different one; on one attempt it got to ~80% done before aborting, another time <10%.
thanks for all the suggestions. at some point in the next few days, I'll  erase the problem drive, see if I can copy my files onto it and then see if I can then copy it onto another HD. even if it behaves at that point, I'll consider it a HD with an 'intermittent' issue, i.e. unreliable. with storage so cheap these days, I won't risk losing my music collection. at that point the problem HD (even if it's behaving) will just be a redundant backup (I'll have 3 copies of the collection elsewhere). I guess you could say it'll be a lightweight paperweight with a ton of music in it?
Can you copy the files in batches instead? You might be running into a memory issue as it tries to do a large # in one go.
New to me, never heard of a problem attributable to a source drive. My money is that it's most likely downstream starting at the connectors.
I cleaned mine but still needed a dock.