TEAC NT-505 impossible connecting to WiFi router o such LAN: help me please?

Hello mates,
I got my NT-505 3 days ago.
It seems to be working correctly but in my opinion all software in not the same level than the device: too aged & often no relevant documentation or support about.
However my big trouble is the NETWORK interface:  since first time I switched on, the NT-505 remains "for ever"  into NET configuring blinking state until it goes in power stand by.

1. RJ45 cable is ok - tested in several manners
2. the wifi router (1Gb fiber connection) is ok
3. the wifi router ether ports (4) are ok - I checked a bridged LAN configuration too

Testing the NT-505 Ether port It results:

1. the physical level of protocol seems working correctly just on-way: the interface recognizes correctly the bandwidth (Fast ot Giga in my case) end the packet coming from the router are buffered. No packet sent  to the router.

2. At protocol level no ARP session are involved hence impossible retrieve MAC address and trying to do something.


1. Being NET board logically split from MAIN board It's need a separate firmware(!!!): how can I upload the NET firmware if, as stated into documentation, I must use the mobile app and It's impossible connecting the device to such LAN?

2. NO menu interface to configure manually the net parameters.

May someone help me (tricks..., recovery sw,..., low level maintance menu...,...) 

Thank you a lot.

Did you buy this unit new? Have you reset to factory default and started over?
I just received one of these as well and have had no network issues whatsoever - it grabbed on right away.

Factory reset probably your best bet then before you do anything with your system move the unit over to a PC and update the software on the unit to 1.22 via the Teac Japan site.  You need a USB to micro USB cable to do this and the NT-505 needs to be directly connected to the computer.

Plug in Ethernet cable, open the Lumin app and you should be in business.

Inital impressions are very good - separation and tone of individual instruments and voices are outstanding, seems to handle MQA files quite well.  Took awhile to get the settings where I wanted them but having the ability to tailor the sound a bit seems to be worthwhile if you have the patience for it.

Hopefully you can get it going in a matter of minutes not hours I'd try rebooting your network as well if resetting and updating doesn't work.
Hello friend,
yes my device is new and performed any kind of firmware upgrade (initially coming with 1.10 rel.)
Just to be clear - from what I understand you can update the NETWORK firmware through the app and over the network but to update the SYSTEM firmware you have to download a file on a home computer, unzip the file and then connect the home computer directly to the NT-505 in order to update the SYSTEM firmware.

I had to pull my NT-505 from my audio rack and connect it directly to my PC in order to update the unit have you done this?
Make sure to use Lumin software app, not the Teac software app for control. Lumin app is more stable and is compatible with the player.

I also haven’t had any trouble with my NT-505. Although I did have trouble initially updating to current firmware version. I was connecting to the USB (the larger one labeled USB) on the back rather than the micro USB (very small, unlabeled, near bottom), but once I figured that out it was good. Sorry can’t tell from your last post whether you have successfully updated to current version or not.

@audiojedi did you mean version 1.21 firmware, or did your really mean 1.22? Isn’t 1.21 the latest?
EDIT:  Nevermind, I see that 1.22 came out now.

OP, sorry for my basic descriptions but you know the NT-505 doesn’t have wifi, correct? It is Ethernet only. No wifi. I think your references to wifi in your post refer to your wireless router, just wanting to make sure you got that which I’m sure you do.
Correct, what audiojedi said. It says it is doing an initial update when you initially get going but that is just the phone app.

To do the firmware upgrade to the NT-505 itself you need to use a PC (not mac) and use a physical cable to connect to the little micro USB port on the back at bottom just above the word "Digital" (which is confusing because the "Digital In" label refers to the optical input, not the micro USB, which isn’t labeled).
I understood that I did not explain correctly my issue: my problem is not the FIRMWARE upgrading via usb rear port (already done several times)
My NT-505 DOES NOT establish any connection to LAN  via Ether port (no protocol session starts hence no IP@ is assigned to NT-505 port by the router) 
In this condition the device results unreachable by anythings running over IP protocol (apps included). This means that I'm looking for an alternative method in order to upload the NETWORK fw.


SYSTEM FirmwareV1.22 -> done (from japan site) and running correctly

NETWORK FirmwareVer11.6c
 ->  not possible because It seems that via app is the only manner to do this.

I have two hypothesis:  shipped without network fw on board or such chip managing the Ether port does not work.

Might check if your  router is set to hand out IP addresses by DHCP. Looks like the Teac is trying to get an address and is timing out. Other than that you could try Teac support it could be a bad chip.
Yes my router is DHCP on. Trying with external DHCP server the behaviour is the same. The devices does not react to ARP req send by router hence MAC@ end IP@ cannot paired in ARP table. Just to understand: normally after rj45 cable is plugged then NET is set like source should the NT-505 work simply? 
What cat level Ethernet cable are you using? (Eg, cat 7?). Assuming you’ve already tried a couple different Ethernet cables right?
It's only going to give a MAC address once it has an IP address. ARP needs the IP address to work. If the Teac doesn't have an IP address handed out by DHCP it's not going to respond to ARP. For some reason it's not getting an IP address try putting the Teac in the same room with the router and connect with a short cable then turn on the Teac if it doesn't  get an IP address there could be a setting wrong go through the menu check that everything is correct. You should be able to go through your input sources   to NET see if it's enabled. 
It may be speed auto-negotiation between the router port and Teac port.
See if you can lock down the "auto" speed negotiation on the router port to either Gig or 100Mbps. If you can lock the speed down on one or both sides this may resolve your issue.
Fasteddie & Djones you could be right. I used for connection a Cat5e cable (1,5m) directly to WiFi router ether port.
All my pc work fine but plugging the NT-505 the 2 leds of TEAC  Ether port remain fixed on green.
I am afraid that i can do nothing to change the lan port setup: I have a simple TELESTRA TECHNICOLOR TG799 with four 1Gbps ports .
Probably the speed causes such problem to NT-505 during its initial DHCPDISCOVER phase.
So I doubt this is the issue, but FWIW when I used a 1m Cat6 Ethernet cable with my NT-505 I would get Tidal music dropouts every hour or so.

Then I upgraded to Cat7 Ethernet cable (1m) and I never get dropouts now. I use a simple AmazonBasics Cat7 Ethernet cable that I paid $7 for.
Ymlee1, my problem is a little bit different.
As I wrote earlier, It's impossible connectig  my NT-505 does to the LAN.
Hence it results unreachable by app o other LAN stuff.

I have been waiting for some talk about this unit. With the exception of Silvio's issues is it a good DAC/Streamer? Does it fully "unfold" the MQA from tidal?

I would be running it via balanced connections into my McIntosh MA8900.
I've been following this thread and one of the things I realized was that I hadn't updated the firmware on the device.  I did that yesterday, and now I can't connect to it, with the Lumin app or BubbleUPnP.  Strangely, I can cast from Spotify to it with no problem.  I'm about to do a factory reset.  

To badger... I upgraded from a Bluesound Node 2/Auralic Vega DAC to the NT-505 and it was a noticeable jump in sound quality, imaging, and soundstage.  Yes, it does MQA.  I really like it, other than my current frustration, which could be an issue with my network.  I've been having some other issues and am not sure if it's the TEAC or the network at this point.  I've ordered a new router and will see if that clears up all the issues I've been having.
Yes, I find it to be a fantastic unit for its $2k price. Full MQA, yes. I run mine with balanced XLR’s to Audio Research integrated amp.

Dual monaural AK4497 dacs, dual torriodal power supplies, fully balanced, two on-board clocks (with provision to receive an external 10MHz clock if you want additional performance), DSD 512, outstanding analog output section, several filter and upsample selection options (or option for none), Lumin software, Roon ready, .... Incredible value. I’d love to hear it compared to a Lumin T2 at $4.5k msrp - wish I had access to one to do a shootout.

Other than the occasional dropout issue I was having first month, which was 100% solved by going to Cat 7 Ethernet cable, my unit has been entirely trouble free for me, and it gets heavy use. 
Dear djones, here in Italy COVID-19 is dramatic situation:everybody must remain at home (I since 30 days).
I have a lot of time in order to play into my HiEnd room: I had tried everything :-) remain only to open my NT-505 then...
I'm joking...take this opportunity to thank all of you for supporting and stimulating my English
Hi All, So I did purchase a NT-505 and my first experience with it was should I say eye opening in terms of audio/build quality etc. However, as most of you here, I did have the same issues with network connectivity. It really seems it’s network controller loves to connect to 100mbits, and as such I was able to stabilize its behavior if I have it connected to simple 10/100 switch. I’m positive the same results could be achieved if you have a 10/100/1000 managed switch, and you can force the port where NT-505 is connected to 100 megs. I am about to open a channel with Teac support and have a nice discussion about these issues with them, and really hope they can fix it in a future firmware release.
Stay safe out there!
Hi Kosta, you right! I performed several test using using sniffer, 100Mb adapter and other stuff: the behavior remain the same It does not work.
I verified your detection is correct. No speed negotiation is supported, no broadcast DISCOVERY message in order starting DHCP session, ...
Regardless of the solution this issue is unacceptable  at €1.6K, in my opinion this device represents how this world, by now, is decadent considering that we are in 2020! 
I will appreciate if you keep me updated about.
May you get me the right contact of TEAC support in order to report my experience too?
Thanks, nice day.
The Teac will only do 100meg have you tried a cheap switch that only does 10/100 between your router and 505 ?
Djones, really not.
An moment I do not have a 100Mb switch to use. I connected directly my laptop to NT-505 via a 100Mb usb LAN adapter. Assigned to my pc the DHCP server role I have however no reaction by Teac. Replacing the NT-505 with another PC, all works fine!!! Why? 
I waiting for a new NT-505 that I'll connect to a device like this:

After that, in case of no result, I believe changing this scrap with other brand streamer.

Hi Silvio/All,
FYI. I did try connecting my DAC via a dumb 10/100 switch, and even though its behavior, and I was very excited about it yesterday was quite stable. I did few restarts, with the power button, remote control, so in a nut shell was doing just great, however, this morning I was unpleasantly surprised when it couldn’t connect yet AGAIN.

I decided to move it to a completely different switch (10/100/1000megs) using a new cable, and the damn thing decided to work again, even with tons of restarts. I have no clue what to make out of this, but really hope TEAC support will give us some useful recommendations how to overcome these problems, and/or expectations when they can fix it, if it’s a device problem, which seems to me its the case here.
I totally agree it’s a quite expensive device and as such we shouldn’t be having these kind of problem with it.
I will keep you guys updated how my TEAC support convo is going next week.

Regards and be safe!
Thank you so much Kosta for your valuable feedback. 
Switches? Cables? Hysterical working?
This is an hard challenge because i believe Ether interface platform (physical & logical) has to be redesigned completely.

Keep me informed about TEAC support.

MBR & Stay at home!!

Oh boy, I will receive mine tomorrow and I am hoping not to have the issues a few of you have been dealing with. Has anyone heard from Teac support?
Quick update: Off the phone with Teac US support, and the consensus was it’s a defective unit. Opened a case for replacement and will keep you guys informed with the progress once I get the new unit.

Found a buddy of mine that purchased his from an European store in Germany, and his works as a charm every time.

On a related note... I was able to get a consistent result with the unit been able to get an IP within 15 secs of switching it over to Network mode, or just turning off/on in Network mode of waiting for been up (warm up) for 5 minutes. In my case it seems something is definitively wrong with it’s network module or power supply, OR who cares what as long as I get a working unit at the end of the day.
Silvio, have you tried having yours up for about 5 minutes to warm up before trying to connect/switch it over to Network mode? May be worth trying to see if that’s consistent with my experience?

Be safe!!!
I've been keeping an eye on this thread, because in this one or another I saw that there was a firmware update available that I hadn't installed.  After I did, I started having a ton of issues getting and staying connected to the NT-505.

My setup is a little different than most in that I have mine connected wirelessly, using a Wireless Access Point configured as a client and then connecting that to a four port switch that I have the NT-505, my Oppo BD player, my TV, and my Roku connected to.  I've been having some issues with my router (waiting for a replacement) and thought that might be the issue.  

I removed the switch and connected the NT-505 directly to the WAP and it seems to be functioning without any issues for about a day now.  I really like mine, but it's troubling to hear of so many issues.  I'm hoping the new router and a new WAP will fix my issues.  It did work OK when I ran a long ethernet cable directly from my router, so it may be that it's an issue with my home network.  I was also having issues streaming Netflix on the Roku, so I'm not convinced it's a problem with my NT-505 yet.
Hi BG, Oh, I'm totally convinced mine is related to my NT-505. I have about 30 WiFi and another 15 LAN devices spread around my house and none of them show any such problems, so yeah, unfortunately I could positively say it's the Teac.

Hope you'll have better luck/experience once you get your new router installed. Good luck!
Sorry that you guys/gals are having trouble. Before this issue I’d never heard of any NT-505 trouble, but I guess it’s probably not that widely owned. Hope Teac gets it fixed or replaces the defective units.

Since I’ve not had any trouble in a year running version 1.21 firmware, I’m sticking with that and not flashing to the 1.22 version. Indeed, I have a lot more trouble with my Bluesound unit than I ever have with my Teac, which has been (knock on wood) flawless for me -
I had the 1.01 firmware, or whatever it was that it came with and other than some initial issues when I first got it, no problems until I upgraded the firmware.  I still think my issue might be network related though, so I'm withholding judgment for now.
Maybe try version 1.21 firmware if you haven’t already?? Which if I recall was from December 2018.
I did notice an improvement going from the shipped firmware version to 1.21. Mainly more stable in terms of dropouts during play is what I found after the switch which I did a week after getting unit if I recall
My unit came with v1.21, but I guess I was too quick to upgrade before I actually did any extensive testing. Not sure if I can downgrade now, especially the network piece which is 11.6.c now after all upgrades. Teac support mentioned v1.22 should bring more stability then anything else in terms of network connectivity, but who knows. I may look into downgrading if at all possible before I do the exchange with a new unit.
I didn’t even know v1.22 existed because on the Teac Europe site they don’t have 1.22, just 1.21.
Wonder why that would be? That’s why initially when you guys started talking about 1.22 I didn’t understand what you were talking about.

in the year I’ve owned mine I never visited the Japan site, only Europe and was always thinking I was current with v1.21. 

Now if you really want to be sure you are getting the version that’s worked great for me, pull 1.21 from the Europe site and skip the Japan site. How bizarre would that be if there were slight differences? Ugh, probably overthinking it ... But still odd to me that EP site no mention of 1.22
Update: Installed v1.21, did number of resets, and nothing really worked. Well there was a lesson learned of course and that was my unit is definitely hosed in a way I can’t explain, but can easily guess its HW related.

My lastest experiments show if I connect it over USB to say my Mac it would always be able to get an IP and be available over the network (go figure). However, if I do leave it to Network mode and power it down, and keep it down for say 10-15 mins and then power up (doesn’t make any diff if HW power switch or remote button) it would not get an IP.
All-in-all it’s going back to Teac (Onkyo here in US). A bit disappointing I was the one of the few unlucky Teac users out there cause according to Onkyo, there are no other reports of such behavior, or don’t want to admit it.
Although might be tempting... stay on v1.21 if you ask me and don’t fix something is not broken :)
I just received my NT 505 yesterday afternoon that I purchased from TEAC direct via *bay (am I allowed to name them?). Once I started the unit up the HR Streamer app prompted me to update the networking firmware to version 11.6c which I did without a hitch. I checked and my unit has the version 1.10 I/F firmware. My unit was automatically recognized by Roon and everything went perfect from there. 

I did follow a link in Roon for the unit that took me to TEAC's EU site where I found a link to upgrade the I/F firmware to 1.21. In looking at the release notes for v1.21 it states that it added "Roon Ready" to the unit. Since mine was already doing that I see no need to upgrade. One thing I did note is that the firmware installation instructions say to upgrade the network firmware before upgrading the I/F firmware.

I only got a couple of hours of playtime with mine but so far I really like it. It's sound is much smoother than the ESS 9018 that is in my Bluesound Vault 2i and the ESS 9038 in my two channel amp. I got it as primarily a headphone DAC/AMP though I am feeding it's single ended outputs to my 2 channel system (Arcam SA 20 amp). The specs say that the headphone amp section max power is only 500mW x 2 so I also bought a used SPL Phonitor amp here on A'gon and it should get here tomorrow or Friday. That should really help out with any hard to drive phones I may (will) acquire in the future.
Since I took the 4 port switch out of the chain, mine has been working perfectly.  Still waiting for my new router, but I think the switch was the problem in my case, not the NT-505.  Let's hope I don't jinx myself now!
Congrats bigfanga. Yep, it’s a great sounding dac/streamer!  I also strongly prefer the AK dac sound to the ESS options I've heard.  But a lot of the Teac's goodness also comes from all the other Esoteric-trickle-down (Teac is parent co. of Esoteric) technology that it has that I mention above, but yeah the AK4497's are great.

big_greg, good luck!

FWIW I have mine connected to a Linksys 5-port switch and it worked fine. I also have an Eero mesh wi-fi system.
@bigfanga I think the switch just gave up the ghost.  I was having some issues with my Roku also, and letting it connect to wireless eliminated those issues.
Bad news by me! Following your several suggestion I connected the NT-505 to router via a simple 5 ports 10/100  switch using a cat. 7 cable:  no way. No LAN connection.
Talking with the supplier, I have asked for do not delivery the replacement but I want to change brand: TEAC is proving itself to be unreliable, aged and  unjustifiably expensive (I remember this stub costs about 2.000,00$). The European distributor complains a lot of LAN hw failure and many customers cancelled the purchase moving to other brands.

With my HiEnd system:

Lector- Italy
Scheu Analog - German
Leema - UK
Audiomods - UK
Axiom - Canada

I never and I say never, although these are not incumbent brand, problems about customer relationship and supporting. 

May you suggest a valid alternative? I am thinking of a beautiful ESOTERIC (eheheheh).

Stay safe my friends.


Bummer - sorry to hear that. No suggestions for alternative but whatever you decide, let us know what you get and how you like it. Good luck!
May you suggest a valid alternative? I am thinking of a beautiful ESOTERIC (eheheheh).
You know that Esoteric is part of TEAC?

From the Esoteric website:  "In order to bring the highest level musical experience to demanding audiophiles, TEAC launched the "ESOTERIC" brand which exclusively engineered and manufactured high end audio products."

When I was looking at streamers the other one I was looking at was Lumin - either the D2 (streamer + DAC) or U1 Mini (streamer only).  I found a good deal and went with the TEAC instead.

Why don't you just try exchanging the TEAC, it sounds like you got a defective one?


Not trying to talk down to you but asking an honest question, did you update the network firmware BEFORE updating the system firmware? I noticed that the v1.21 update instructions stated that it must be done in that order.
Dear bigfanga,
your words seem just a lit bit offensive: probably you have to pay attention to all thread starting form top.

From my initial request:

since first time I switched on, the NT-505 remains "for ever" into NET configuring blinking state until it goes in power stand by

Continuing (please notice the number 1 means first step after I read the doc!!):
1. Being NET board logically split from MAIN board It's need a separate firmware(!!!): how can I upload the NET firmware if, as stated into documentation, I must use the mobile app and It's impossible connecting the device to such LAN?

In this condition,  what would you have done? 
Hi Silvio66,

Did you manage to get a solution.  I have an NT-505 and recently I cannot get it to work on NET at all.  It doesn't appear to get an IP address from the router, I have tried new cables, different routers, and still yet to figure out what the issue is.