Qobuz iPAD app and high rez

I was playing about with the Qobuz iPAD app tonight streaming directly from the iPAD to my DAC via lightning port to USB.  I notice on a Hi Rez track the DAC was indicating 48Khz even though the track in the app was 24/96. I fiddle around with it and discovered that to get the full resolution you have to download the file to the iPAD then play it.  Anybody else notice this? Gonna compare the SQ of this method to ROON soon.
I’ve not heard of this either and doesn’t sound right to me.  Check the settings in your Qobuz app and make sure you have the resolution settings set to 24/96 (I don’t think Apple passes anything higher than that out of the Lightening port but could be wrong).  Hope this helps, and best of luck. 
@soix Qobuz default setting is set to 24 / up to 192 Khz.

I select a high rez album. When I click the "HiRes Audio" badge I get a modal pop up that reads:
"How to Listen to to 24 Bit with Qobuz. Offline streaming and import in 24 Bit are available to subscribers: Sublime | Studio. Qobuz download customers can listen to their Hi-Res purchases from the app as well. In that case it is mandatory to download the release first. High Res audio needs a the use of a compatible device; " a DAC"
If I click play and stream there is a small box below the album art that reads: "CD Quality" and My DAC indicates 44Khz.

If I download the track into the app and play it from there the DAC will show the high resolution (e.g. 88,96 etc).

I shipped off a question to Qobuz help site.  See if they know what I am doing wrong.

First, I don’t know what hi-res badge you’re referring to — either a track is available in hi-res and is labeled that way or it isn’t.  Second, I’ve never gotten or seen the pop up you mentioned, ever.  Third, I just fired up Qobuz and tried three different resolutions — 16/44, 24/48, and 24/96 — and they all played at those stated resolutions as per my Dragonfly Red.  

One thought — Qobuz just revamped their subscriptions not too long ago and maybe your subscription didn’t automatically switch to one with hi-res streaming?  Just spitballing but would like to know what you hear back from Qobuz.  Best of luck finding a solution. 
Same behavior on phone
I’m starting to suspect some compatibility issue with my DAC
Hopefully Qobuz gets back tomorrow.
Fixed. User error. I opened a case with Qobuz and it took some time but they were responsive. I mansplained to them the problem but it took multiple emails and screen shots. They directed me back to the settings->streaming settings and there I discovered there are 2 sections for the resolutions settings, Mobile Network and Wifi. I failed to scroll down and see the Wifi sections settings. I just assume there was only one resolution setting. Once I set Wifi to the highest resolution it worked. Egg drips from face emoticon.
We’ve all been there man and feel your pain.  Congrats on sticking with it and finding the solution, and enjoy!!!