Aurender Conductor latest fail…

Anyone having issues with the Conductor app force closing whenever you attempt to select an album or favorites? I’m assuming it has something to do with the latest iOS update which I did on my phone and tablet yesterday. 


Please confirm your Aurender components, including, the Conductor app have been updated. 

Please delete the Conductor App from your iPad and reinstall it. If that fails, please log a remote support call with Aurender.

My Conductor App version number is 3.22. You might need to go to the App Store and install the newest version. If still not working, log a remote support call.

 I could never get Aurender to work reliably for me, so I gave up on it. "Ari" in support wasn't much help. My Bryston BDP-3 has been rock stable.

@jl1ny, Have any of my suggestions above worked? If not, please create a remote support call.  Go to settings and look for remote support  

My Aurender N20 is working fine and Aurender customer support has been excellent.


I’m at work right now, before I left my apartment I reinstalled the app and sent a service request to Aurender. They have been pretty quick at responding. Hopefully this is a easy fix.

I'm having the same issue with my N20. It started yesterday. Will reinstall the app to see if that resolves the issue.

Hey guys…I received an update from Ari:

“This is a universal/systemic issue that began on the morning of March 29. We have successfully diagnosed the problem and a Conductor app update has been released to the App Store to fix the problem.“

Aurender is really responsive to issues. I got a response within an hour of reporting this. 

My A10 started doing exactly that on my IPAD.  I reinstalled the app several times yesterday and am still having the problem.  I will delete and reinstall it tomorrow and see if the problem is remedied.  If not, I will create a support ticket.  Sounds like it should be fixed.  I'll try tomorrow.  Conductor lite has continued to work on my iphone.   

I know this is an Aurender thread, but I had the same issue begin with my Auralic Lightning DS two days ago and logged it. It was only for Qobuz albums however, Tidal was working fine. Today I can access them fine except for one, which happened to be the album I found this issue out from which is very odd, it’s ‘Superdream: Analog Sessions’ by Big Wild.

No issues here with Aurender app and always a stellar experience dealing with Aurender support. 

Update: the IOS update for the Conductor App is not available yet. I reinstalled version 3.22(4) and the issue persists. The updated version 3.23(0) will be available in a few days. There’s also beta version for those who like to test drive.

I reinstalled conductor this morning and I'm having the same issue.  Thanks for the update re 3.23.  I think I'll wait a couple days and just use my iphone. 

Aurender told me it takes a few days to get the mod through Apple. There is a beta you can download from Aurender… just sent them a message. I’ll just wait.. I have tons of files on my unit… good excuse to,play them.

The problem started yesterday and is universal. Aurender is working on the fix which will likely take a few days. 

I don't know if this is Kosher to post but see this thread. I installed the Beta and I have Qobuz again with my iPad and W20. 


@jl1ny I really take exception to the title of this thread. It is an Apple problem and another reason why I don't use Crapple.

So address threads honestly and better still get an cheap Android tablet to use exclusively with your Aurender.

Just remember Apple is not trusted in the real world for critical computing.

Don't be a clown.

Post removed 


Sorry champ if my post offended your sensitivity. The title says exactly what it is…the Aurender app failed, not my iPad. But thanks for your wisdom. 👍

@jl1ny Yeah it's like saying my car failed because it ran out of

The Aurender Apple App stopped working because Crapple updated iOS.

Woke can't see reality.

I noticed the problem today, sent Aurender Support an email, received a response in less than two hours with a link to install a beta version of the updated app that will be available to all in another couple of days or so, installed it, and now it is working perfectly again. The whole process took about ten minutes or less.

I'd say in this instance that customer service was first rate.



Wrong again champ. It’s the responsibility of the app developer to ensure their product maintains compatibility with iOS, not the other way around. But I really do appreciate your help. Thanks 👍

It is always enjoyable when people that hate Apple, get so offended when other people choose to use their products. It’s cool, you don’t like Apple, but I happen to much prefer the user interface than android. I don’t see people bashing android to those that love it, it’s a very odd interaction with Apple haters.

For what it’s worth, the Auralic update is out and in the description it says, ‘fix the Qobuz crash issue due to server content change’, so perhaps the issue was Qobuz not notifying the software developers of some changes rather than Apple being the devil…

Conductor App 3.23 is in the App Store. Up and running again. More of the fantastic customer service we’ve come to expect from Aurender. 

interesting- Auralic's DS Lightning app also recently had am update and Auralic users were then experiencing DS crashing when selecting a favorite album. Wonder if both updates were prompted by a Qobuz update and then similarly affected both Aurender and Auralic users.

My takeaway:

Aurender was responsive and fixed the issue. Quickly, too. It's only been a few days. Can't really ask for much more than that.

Apple makes brilliant devices, which I don't use. PC and Android everything. But I'm okay with other kids having nice things, too.


Your Einstein quote is a paraphrase of a comment attributed to Jean Cocteau. 

"I didn't really say everything I said. " Yogi Berra

He later added: "I might have said 'em, but you never know." Gotta love Yogi!

Let's have fun!



Wasn’t me who posted the quote…it was that anti-Apple guy. 😂

between Aurender customer service and the input from members here, I’ve never had an issue go unresolved. 


My apologies. Sure glad I dialed back the snark! Petards are everywhere ready to hoist us all.

That wasn’t my experience. It’s a pet peeve of mine to get suggestions from a tech that reveal he never read the original trouble report, or what had already been tried to remedy the problem. Ari seems to be the only Aurender tech in the US, and that’s why I gave up on Aurender. Life is too short for that kind of nonsense.

Post removed 

Ari has been really responsive and the fix inserted itself in my iPad, issue is gone. Great customer service.



Glad that you are enjoying the Bryston BDP3.  My experience with it was terrible.  And talk about a shortage of techs-Bryston had one guy responsible for troubleshooting their digital products and for writing the code to the dreaded Manic Moose.  When he was on vacay, it was SOL.

  I have no experience with Aurender


Glad that you are enjoying the Bryston BDP3.  My experience with it was terrible.  And talk about a shortage of techs-Bryston had one guy responsible for troubleshooting their digital products and for writing the code to the dreaded Manic Moose.  When he was on vacay, it was SOL.

That's interesting. I've only had one issue with the Bryston in the 18 months I've owned it, and it was resolved remotely within hours. My Aurender (brand new purchased from an authorized dealer) couldn't last a week without issues. Aurender has one tech guy in the US ("Ari") and it sometimes took days for him to respond to an email trouble report. And then, as I noted, his responses sometimes indicated hat he hadn't read the trouble report.

As for the Bryston Manic Moose interface, I use it mostly for Qobuz. Usually I use Rigelian.

It's interesting how different users have different experiences. @mahler123 what are you using to stream now?

This stands in sharp contrast to the complete lack of support offered by Roon.  I spent weeks dealing with setup issues with my Roon Rock server that probably could have been solved by a technician from Roon in a 10 minute phone call.  Absolutely arrogant company.  Quit Roon and the NUC and went with Aurender.