Decco USB Connect Not found by Windows XP PC

All.... I really need some help here. I have a Toshiba laptop with ITunes 9 that I was connecting to my Peachtree Audio Decco via USB and things were working great the first week. I go away for a week, come back and now my laptop says USB device not recognized when I connect it back up. It recognized it the whole first week?

Microsoft does not have a place to download a USB driver(Service Packs are it). Has anyone had this same issue, and if so, have you been able to solve it. WHen I look in the device manager, USB2 is shown, but then I connect the Decco and walla, "USB Device not recognized".

I am quite PC literate, and have had a music server running my sqeezeboxes for 3 or 4 years, so I'm not a rookie here, but I am flumoxed on this one. I would really appreciate any gurus out there, or someone from PeachTree/Era, if they could help me on this one. Hopefully, upgrading to Windows 7 isn't the cure, nor buying a Mac Mini from you Apple polishers. Thanks in advance for any assistance.

Got Vista, I presume?

I do and sometimes depending on how things are started up, the right driver is not automatically installed for various USB audio devices.

Once I had to change the driver or find one, I forget which, and simply chose the option to have Windows/Vista look online for one. Another time I found the device in the uninstalled hardware area and just selected it & then, 'install'. A driver was found in the Vista OS.

In the audio section of control panel "Sound", whatever is connected and up & running when it's plugged into USB port it does show up in there.


Try starting up the laptop without it plugged into a port. Turn on the gizmo and then plug into a USB port. If nothing good comes from that, try another port. Oddly enough that can work... or has on my toshiba L350. there is a servidce pack II for Vista too... albeit it had said, beta when I downloaded it.

Weird but true.

Past all that perhaps downloading a free ASIO driver might work.

Good luck.
Oops. missed the xp part.

with SP 3 you should be good to go... and only some change in the start up (connected, unconnected, one port or some other) should be all that's necessary. Only my xp pro box is almost as picky as is my Vista laptop with such things.

check the Add hardware list once hooked up and see if it's there.

If it worked once, it will again.
>"I am quite PC literate"

OK, then. "Plug and play" should make this work.

Unplug all the USB devices. From "Computer Management" - "Device Manager", select each of the nodes below "Universal Serial Bus controllers" and right click - Uninstall.

When you have removed those, you have no USB controllers, so reboot the box, with no USB devices plugged in, and let it rebuild the generic Hub controller and others it wants to do. Wait until it settles down. Check Device Manager and see what's there.

Now plug in the Peachtree Audio Decco USB connection and XP will activate "Plug and Play" and install an appropriate driver. If it can't find one on the hard drive and asks for the CD that came with your Peachtree Audio Decco, then do that.

Did it come with a CD?

The manual for the Decco indicates that no special drivers are required. And if you are seeing USB2 indicated in Device Manager it would SEEM to confirm that your Windows installation is sufficiently up to date to be able to handle the port without additional software, which would also seem to be confirmed by the fact that it worked initially.

But just to be sure let me ask the following questions, even though they apparently are irrelevant: What is the model and approximate year of purchase of the Toshiba laptop, and which Windows service pack has it been updated to? Are you using the software installation it came with + updates, or did you ever reinstall the software from scratch? If you reinstalled the software from scratch at any point, did you run an Intel Chipset Software Installation Utility?

Beyond that and the suggestions which have been offered by the others, and besides re-booting everything which I assume you've already tried, I would suggesting trying the Decco on both a different usb port and on a different computer. Unfortunately it seems conceivable to me that either the computer port or the usb interface on the Decco could be defective.

Good luck!
-- Al
Thanks to all three of you for responding.

Some added info. I have 3 Decco's here at my beach house. All 3 are acting the same way. Unfortunately I don't have another computer with me right now. I have swapped out all 3 Decco's with multiple USB cables.

Metralla- Trust me plug and play is not working. I'm head of my IT dept for a Defense agency of 10K staff. I'm not trying to be a smart ass, but when I say I'm PC literate, I'm not trying to brag, but are a little up from a "novice" in this arena. I did what you stated on my own and rebuilt things. I know there are only 6 drivers for USB for XP. I talked to MS and they told me Service Pack 3 should pick it up. It shows USB2 and Hub support in the device drivers when it's rebuilt.

Almarg - Model is M65-S821 purchased about 3/4 years ago. Operating system has been rock steady, believe it or not, and all patches and Service Packs up to 3 have been installed. I patch things nightly on this and all my boxes when there are patches available.

The crazy thing about this is the first time I got the Decco's out of the box, they came up no problem and worked for the week we were here in July at our house. Now I come back in Sept/Oct and it says,"USB Device not recognized", but it looks in device manager like all drivers are there and I went through rebuild like Metralla said just to go clean slate, since I know fungu happens in this business. I guess next step is to reload XP from scratch, or just wait a week until Windows 7 disk arrives, huh.

Thanks again for all 3 replies. My TT sounds good through the Decco while I trouble shoot and keeps rock and roll flowing here at the beach.

Hi Mark,

Have you tried connecting some other kind of usb device to that same port on the computer, to see if it is recognized properly and works properly?

-- Al
Mark -- A further thought: Perhaps during the intervening two months the main battery discharged, and perhaps the small coin-type battery that is located internally somewhere on the motherboard, and which allows the cmos (bios setup) settings to be maintained, is dead (considering the age of the laptop).

Besides trying some other kind of external usb device on the computer, I would go into the bios setup screens and examine the usb-related settings. As you probably know, that is usually done by pressing either "del" or "esc" or "F2" on the keyboard immediately after the computer is turned on, before Windows starts to load.

-- Al
Mark -- A followup to my previous post. I found the manual for your computer here. As indicated on page 108, the cmos battery (referred to as the RTC battery, because it saves the real-time clock settings as well as the bios configuration settings) is rechargeable on that computer; and it will hold the settings for only about a month when the computer is turned off; and it only recharges when the computer is turned on. That is all unusual in my experience.

Also, apparently on your computer the bios settings are viewed and changed via a software utility that is installed into Windows, rather than by the usual procedure of entering bios setup prior to boot. See page 200 and 201 of the manual.

Hope that helps,
-- Al

Thanks for your continued help in trying to solve this crazy sitution. I have in fact connected other USB devices and they are found by my laptop. In an hour, my cousin is bringing his laptop over to our house since he's near us in NC so I can try it with my DECCO.

I have checked the battery, and it appears Bios settings are good and the battery is not dead. I wish that were it. Wouldn't that be good.

I was trying to back out the Service Pack 3, but am unable to do that without reloading the OS. Don't want to go there yet with Windows 7 a week away.

Really appreciate all your help.


I got the answer to why my Decco wasn't working. It turns out the USB card shorted out due to the ground not being soldered correctly, according to Signal Path, the manufacturer. There was nothing wrong with my Toshiba laptop, nor the other two laptops we tried with them.

Thanks to all of you who tried to assist me in fixing my PC, which it turns out is fine. LOL. I guess I'll be boxing up both of these units to return to have them retro fitted with new USB Dac cards.