Bluesound Node 2 producing distortion and dropouts

I have my Bluesound Node connected via co-ax to a Chord Hugo TT-2 and have been experiencing some issues as of late. When I start to listen to music I sometimes have a distortion with dropouts. I have found that if I unplug the power cord on the Bluesound and press the buttons on the top and re-plug the power cord, the issue goes away.

is anyone else experiencing this? Is this a signal from the Bluesound that is starting to fail and I should start shopping for a replacement streamer. A little background, I originally bought this unit 3-4 years ago,new. I used a Rega DAC then a Chord Cutest and about 6-8 months ago the Hugo. Until a few weeks ago I had great service from this unit, so I don’t feel the DAC is related to the issue. I mainly am using Tidal and Qobuz for streaming.

any insight is greatly appreciated, thank you.



Are you using wifi or connecting your Node via ethernet/LAN? I had a similar issue where wifi stopped working properly and I was experiencing lots of dropouts especially when playing hi-res music. It turned out that I had installed a Google Nest doorbell which was somehow interfering with the Node. 

Arafig, I forgot to mention that. I am using ethernet and have recently upgraded my internet service. 

Thank you for bringing this up. 

Try putting in a support request [Help/Send Support Request].  BS can look at your log and possibly diagnose what is causing the problem.

It may take a day or two for them to respond.  In the meantime, try posting your question to the Bluesound Community Forum.  They monitor those posts and may be able to suggest a few things to try right away.

dinosore, I figured since it was out of warranty they wouldn't help me. But I will try that and see what they say. Also is that community forum found on the bluesound website or is it here on I wasn't aware of its existence. 

Thank you for your help 


I have the same issue with 14 month old node n130.Started about 6 weeks ago.Node will disappear from player draw,my pulse speaker and blusound soundbar are still there.The node is connected with ethernet cable,Happens about every 5 days.Unplug node and it then works normally.Tryed router reset procedure,same issue.I wonder if it's related to last update?

To go to the bluesound forum.In the bluos app go to help/online support/scroll down to community/join the conversation.

donlp33, Thank you for your response and the way to find the forum. But I hadn't thought of a error on the last update. Maybe Bluesound has a fix in the works, but I will send them an email dinosore suggested and make sure that they may have an issue brewing.

Thanks again


Sorry to hear you are having problems with your Node 2. I have one I bought 6 years ago new, and it's been running like a champ ever since.

theo,My node just updated 5 minutes ago to version 3.20.49.No info on bluesound sight that I could find about update yet.Maybe this will help with the issue?

Mr-m mine was new 4 yrs ago and has been performing great until this past month. I hope it self corrects so I can continue to enjoy it.

donlp33, I have 3.20.45 and have tried to do an update but I get the “no update required “ so maybe it will come in the next day or two. Thanks for letting me know.



Bluesound node was always problematic for me with wifi.

My puls mini is better since it is hardwire.

but… my issues with internet service in a very rural spot is where I have issues..

buffering, restarting, just break up of tracks..  really frustrating..  even the starlink exhibits these issues.  Streaming lower bit rate is more “successful” yet hardly satisfying.  Local lan from san is best.

Tmccarthy, that thought is on my radar here as well. I am hoping it is a software fix as that keeps money where it belongs. But I may be in the market for a new streamer. I would welcome any suggestions in the 1500 or less price range.

I’ve been having a problem with the Node disappearing from the drawer every day or so.  It began after the latest update to 3.20.45.  BlueSound worked with me and reviewed the logs.  After some back and forth, they essentially said they see a problem but it will take a new release to correct.  I’m in the habit of just rebooting it every morning now.  


My N130 stops working every two day like clockwork. I turn it off and turn it on and it’s good for the next two days.  Hoping todays update helps.

Randymap, that is the same version I have. So that must be the culprit. donlp33, mentioned he now has version 3-20-49 and seems to have solved his. So until then I will be rebooting as well, at least I can do that from the iPad.


thank you 

Interesting.  I got my crossover back and thought it was just everything breaking in. Yesterday, clear as a bell. I have 3.20.5.  Brand new update?  Also, I put an aftermarket power supply in mine.  The vendor stated the original power supply caused parts to get too hot and fail due to positioning on the OEM PS board.

I had a similar issue with two Bluesound units each after several years of use.  They are doorstops now

I don't get distortion but do get an occasional drop out.  Mine Node has a wired connection.  I find it is due to a needed upgrade or my device (new ipad or Node) needing a reboot or software restart, or just a function of my ISP.   We usually reboot our computers everyday but my node/ipad may not get a full reboot for months.  

I got a response from Bluesound and they suggested a different cable, but I really think that is not the culprit as I have been  using this Kimber D-60 for a few years. I see that the upgrade donlp33 mentioned 3.20.49 is coming but I can't seem to download it yet.

Fingers crossed!


I've been looking into the Primare NP5 Prisma MK2, supposed to be a little better than the Node and only marginally more expensive. 

I've been concerned about the reliability of Nodes too. 

I will look in the Primare, we have a good dealer locally. Also I have looked into the Cambridge, but hoping a software update from Bluesound will be a fix. Financially I have to wait, I just paid income tax and property tax and my wallet has an echo.

Good luck with the update, hope it fixes everyone's problems. Nodes are pretty much a staple entry level streamer. I hope Bluesound doesn't start taking that for granted. I'd have already got one for my office system if I haven't heard so much negative chatter.  

Cambridge certainly has a few streamers in this price point. Just seems folks don't like their app...?


My problem with the Node disappearing from the drawer every day or so, which began after the latest update to 3.20.45, seems to have been fixed with the latest 3.20.49 release.  For 5 mornings in a row since the update, neither my N130 nor my Powernode have disappeared. 

I am happy to hear that it was an update issue amd the new update seems to be resolving these issues as per a few members that have reported. My problem is that when I try to install or request an update via the uprade button, get the response "No Updates available" . Bluesound must roll out these upgrades/updates by region or something, as some have indicated that they received it already, which makes no sense to me.

Holding onto some hope here

Thanks for all the help

I just read on the Bluesound site that the 3.20.49 is only applicable to the Node (latested version node) and not the 2 or 2i. So back to square 1.